Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

MeMO

Two-player card match game [Amiga] 路 By RETREAM

MeMO Gameplay video :)

A topic by 8080 created Jul 03, 2021 Views: 216 Replies: 10
Viewing posts 1 to 3
(1 edit)

Very well done, Fun & addictive game 5/5

Developer

Thanks a lot :)

The video shows a lot of corrupted graphics, which never happened on my A1200 (with and without accelerator board), nor in UAE: could you tell me your system specifications, please?

FS-UAE 68060 AmigaOS3.2,  I did notice it crashes AmigaOS on exit (quit the game), what is trashed, to me it looked great 馃樀

Developer (1 edit)

The grey and black displaced and cut "cards" (for example, the one that appears at 2:07 in the video, after the removal of the Switchblade II cards) are artifacts that simply shouldn't be there.  Also, the title screen is heavily corrupted at 10:54. Those artifacts denote wrong memory writes, so I'm not surprised by the crash on exit (which is another thing that never occured neither was ever reported to me). AmigaOS shouldn't matter as the game turns it off and hits the hardware directly. I guess it's an emulation issue. I'll try to see if I can reproduce it.

EDIT: I've played the game for a while on UAE with 68060 as the emulated CPU, but everything worked fine; I'll ask one of my testers to try the game on his real 68060 + AmigaOS 3.2 machine(s).

I've tested on both x86 & ARM version of FS-UAE and some different settings, no luck, even AmigaOS 3.14 & game graphics totally scrambled fast flicker dots/lines but seems game is still running... hmmm I do run a lot of stuff on my Amiga and rarely something like this would happen

Developer

Just received this test report: "Graphic all crisp and clear and sound same..no issues on real 060 and OS3.2"

It looks like it's an issue with your setup - which means that, unfortunately, I can't help :/

I have done more testing, 68020 no errors, 68030 title screen some strange lines, 68040 & 68060 a lot of errors and can crash on exit. at least I can play it error free on 68020 settings, I am using latest Library same as those that came with OS3.2 but as I sad earlier some older software I've seen some strange error but beside that nothing, I'll probably been doing some more tests in future ! What app have you done the game with? Great game !

Developer

I'm afraid your emulator and/or system must be broken:
 * I have a real A1200 with a 68030 accelerator here, and the game has been developed (mostly) on it,
 * for a while, I developed and tested the game on an A4000 with 68040,
 * I have developed and tested extensively the game also on WinUAE, with a variety of settings,
 * my testers tested the game on a variety of system (the last of which is the 68060 + AmigaOS 3.2 mentioned earlier),
 * I never received a report regarding corrupted graphics,
so it's pretty safe to say that the game works just fine.

The game is coded entirely in assembly. For the graphics, I have used mostly Personal Paint. For the music, I used originally OctaMED SoundStudio and MilkyTracker afterwards.

Found the problem "Picboot" somehow overwrites your game !? I had other problems with Picboot that I thought was solved but this time I'm deleting it...

Developer

Glad you found the culprit! Thanks for having let me know.
(BTW, never heard of PicBoot before.)

Read about it at Aminet.net ;)