Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Spellrazor

Spellrazor - a haunted arcade game from 1981 · By Fluttermind

Support Thread Sticky

A topic by Fluttermind created Jan 18, 2016 Views: 612 Replies: 13
Viewing posts 1 to 6
Developer

Let me know what's not working for you. The more detail you can give, the better.

- Version number (0.9.5 etc.)

- Hardware (PC, Mac etc.)

- OS type and version (OSX El Capitan, Windows 8, etc.)

- Repro steps (What you were doing in the game before things went wrong etc.)

- Bug (What happened?! etc.)

(3 edits)

Fullscreen on laptop's external monitor uses wrong resolution

Playing on my laptop, with built-in screen 1366x768, and an external monitor 1280x1024. If I drag the window to the external screen and hit [tab], it does correctly go fullscreen on the external monitor, but it looks like it's rendering to a surface which is the size of the laptop built-in screen's resolution. So, in my case, that's wider than my external monitor, so the right part of the screen is cut off. I can only see "Time" and "Gol" where it should say "Time: 99" and "Gold: 0". Vertically, the game doesn't take up the full height of the screen, and is positioned up against the top edge of the monitor, leaving a big black gap at the bottom of about 20% of the monitor height.

Playing on my laptop's built-in screen is perfect, either windowed or fullscreen.

Spellrazor v0.9.5, on Ubuntu 14.04

This isn't a bug that bothers me (I can play happily on either screen), and I understand you aren't supporting Linux. Just reporting in case it turns out to be useful (maybe it happens on other platforms too?)

Am LOVING the game though. Saw it mentioned on rockpapershotgun. I'll be sure to post something about it on facebook, etc. If you ever put out a paid version, consider me signed up.

Developer

Okay. I can help you out here. Download the Mac version. Open the app folder, go into resources and grab the Spellrazor.love file from there. Use that. I fixed a LOT of screen issues, so this might work.

(1 edit)

You are the BEST!

Sad to say, it doesn't fix that particular bug. It does change the behaviour somewhat: The 'blank' border at the bottom of the screen is no longer blank, but I can see distant '?' monsters in it, but that looks a little weird because the 'bottom of the screen' line, with my spells in it is still around 20% up the screen.

But this doesn't bother me - I can happily play on the other screen And now I have up-to-date goodness, and am self-sufficient in staying up-to-date. My, you've been busy!

Developer

Ouch. That's annoying. Sorry about that. I don't have access to a spare monitor, so I'm not sure I can fix this easily. Glad you're enjoying the game though.

Game hangs

I'm playing 0.9.14b "Brains" on a Mac laptop running OSX 10.10.5. I entered an exit portal from... whichever is the second level with a treasure room. Level 5? The game froze and I got the spinny Mac beach ball; had to Force Quit the app.

This could be an OS issue or it could be the game. I had exactly 1 second left on the timer when it froze, though; if I have the patience to try to reproduce it I may attempt to again leave a level at the last second and see if that does anything fishy. (I have successfully exited this level on this build in the past. Maybe even during the last few seconds of the security timer, though perhaps not with exactly 1 second left.)

Developer

Thanks. Will look into this. That's the problem with fixing bugs - sometimes new ones creep in.

Developer

Okay - spent this morning chasing this. Got to level 12 and nothing bad happened. Admittedly, I didn't get the 'perfect' timing you speak of, so I can't guarantee there's no hang, but seeing as I've been playing since 10am, it can't be too common. I'll keep an eye out though. Thanks for your help, as ever.

(1 edit)

As a hint for anyone else trying to play from linux: older versions of love2d seem to have trouble compiling with newer libraries on my modern linux system, so installing older versions of love2d to run this game is difficult at best. However, the game runs without any tweaking on my part under wine buttery smooth, so that's the option I've been using.


To the creator since I'm here: thanks for the nifty game!

Developer

Thanks! Sorry to hear the news builds of Love aren't playing nice with Linux. Not quite sure what to do about it. That said, it should run with the latest Love2D (did so today) so you shouldn't need to use older versions, unless I'm missing something.

(2 edits)

With both the distro-provided love 11. 2 and the AppImage off https://love2d.org/, I get the following error as soon as I run:

love Spellrazor.app/Contents/Resources/Spellrazor.love
Error
main.lua:268: bad argument #3 to 'newCanvas' (table expected, got string)
Traceback
[C]: in function 'newCanvas'
main.lua:268: in function 'load'
[C]: in function 'xpcall'
[C]: in function 'xpcall'
Developer

Ooh. That's wacky. I'll look into this.

Developer

Wanna try this? https://www.mediafire.com/file/7no7jwubf98jakr/Spellrazor.app.zip/file

(3 edits)

Thanks. Unfortunately still getting the exact same error (literally character-for-character the same) with the .love file from that archive. Please don't feel obligated to troubleshoot this for my sake; I do have a perfectly acceptable way of playing the game with wine. :)

If you do have a linux system handy, it would be interesting whether you're getting the same error with the AppImage from https://love2d.org/ which should guarantee the same environment. From my cursory glance through the docs at https://love2d.org/wiki/love.graphics.newCanvas, it appears you're trying to invoke newCanvas in a way that was removed in 11.0, so I'm honestly surprised to hear that you have it working with 11.2 at all.

EDIT:

I can confirm that running the following sed command seems to fix things without any glaring issues for love 11.2:

sed -i 's/, \?gCanvasMode, \?0//' main.lua

Nevermind. You just end up with a new error once you get past the main menu:

Error
game/StateGame.lua:179: bad argument #2 to 'newSource' (string expected, got no value)
Traceback
[C]: in function 'newSource'
game/StateGame.lua:179: in function 'switch'
game/StateMenu.lua:404: in function 'startGameFromMenu'
game/StateMenu.lua:383: in function <game statemenu.lua:380="">
library/CWindowDialog.lua:42: in function 'keypressed'
main.lua:773: in function <main.lua:747>
[C]: in function 'xpcall'</main.lua:747></game>

To me it looks like, it's probably best to either just recommend wine for linux users or actually create an appimage as described at https://love2d.org/wiki/Game_Distribution.