Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Gumgem

Rescue the prince in a procedurally generated castle! 路 By DAZEL

Black screen when launching the game.

A topic by Waifu4Life created May 16, 2021 Views: 482 Replies: 6
Viewing posts 1 to 2

Hi there,

I get a black screen when launching the game, I only heat sound. I'm using the build that was released today.

Cheers

Developer (1 edit)

Hi! On which OS are you playing?
Does the game start in fullscreen mode?

Also, what gpu do you have?

Hi there,

I'm running Windows 10 build 2004. As for the game, it starts in a small window, but goes full screen by itself. Hitting Alt+Enter doesn't seem to make it go back to a window mode.


Cheers

Developer

I see, that behaviour is normal, the game should load while windowed and then goes fullscreen.
As for the black screen, I can't reproduce it on my machine, seems like an issue with graphics drivers. Try to update them if you are able to.
Do you have an old gpu? An integrated one? What model is it?

I just uploaded a small patch for the Windows build (2.1.1) that enables the fallback to an older version of OpenGL ES if the required one isn't supported, let's see if it makes a difference. Consider that using this previous version of the graphics libraries a few visual effects aren't available.

Thanks!

(2 edits)

Well here's a screenshot of it running in window mode by hitting F11, same thing. This was the first time I've tried playing the game, never ran it before, so I don't know if older builds did this. As for my GPU, I'm running a RTX 3070, so I think I should be OK 馃槣

EDIT:

I just tried running that old DEMO you have on the page, I get a similar issue except that I see this character art in the middle of the screen. Do you have compatibility issues with AMD CPUs?


Developer

Alright, the issue may be related to an Nvidia Control Panel setting.
Disabling the feature to force quality settings on applications should work, leaving applications themselves to decide.
Specifically, forcing MSAA seems to cause the issue, but selecting this option should do the trick:
NVIDIA Control Panel - does "Let the 3D application decide" invalidate  global settings in advanced 3D image settings?: nvidia

(+1)

That did the trick, thank you.