🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Error when opening the Itch App

A topic by kylestra created 28 days ago Views: 60 Replies: 7
Viewing posts 1 to 6

About 2 months ago I on a link to open the Rise of Industry Recipe Book inside the Itch app.  It got stuck partially downloading this and will not finish downloading or cancel.  You have to end the itch process to close it.  I have tried uninstalling Itch including uninstalling in safe mode.  Nothing seems to work.  As of right now I can't use Itch for anything.

Admin

Hey there,

Which version of the itch app was this? Please go to Preferences -> Advanced -> click Open App Log, and paste it here.

Admin

Also, do you have any antivirus software running? Which version of Windows are you using?

I am using Windows 10 home version 1703 64 bit with the latest update.   I just downloaded the latest version this morning.  Once the app is open I can't click on anything.  The app opens and opens a box asking where do I want to save the file, but it won't finish saving or cancel.   Along the top of the app there is an orange progress bar on the save that gets anywhere from 30-80 done and stops.  Clicking again, can change the bar to less that before or more.  Changing locations to a new folder doesn't solve the problem either.

  The only antivirus running is Windows Defender

The computer itself is I770K, it has 32 GB of ram.  The video card is a NVIDIA GTX 1080.  There is 808 GB free on the C drive, which is a Samsung 960 EVO SSD.

Admin

Can you send a screenshot of your entire screen when it asks you "where to save the file"? I don't recognize that as coming from anywhere in https://itch.io/app (that is what you're installing and running, right?)

Ok, this is what has been happening.  It happens everytime the Itch app opens, and requires task manager to close.  It started when I tried to open the recipe book you see listed.  The recipe book opens just fine, but this is how Itch opens every time.  Like i said it is after uninstalling from regular and safe mode and reinstalling the app.


Admin

Oooooh I see, you have a tab open with a webpage that tries to download something. I have no idea how the app handles that scenario, but at least I know how to reproduce the issue now, let's see.

Thank you for all of you're help