Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Sprytile

A Blender add-on for building tile based low-poly scenes with paint/map editor like tools · By Jeiel Aranal

GTLF/GLB models blurry in Godot Engine

A topic by badcherry created 17 days ago Views: 32 Replies: 2
Viewing posts 1 to 2
(2 edits) (+1)

I just wanted to post this in case anyone has the same problem in the future. Adding a GTLF/GLB Sprytile model to Godot 3.2 makes the textures all blurry. To fix this: 1) create a new spatial material; 2) Add the texture image (reimport as 2D Pixel) used in blender to Godot, and add it to `Texture` under the `Albedo` tab in the inspector; 3) Make sure the `emission` tab in is `DISABLED` (this should make it not blurry); 4) Turn 'Metallic` under `Metallic` to 0 (This should make the colors look correct).

Developer

Thanks for sharing this info! I'll consider adding this to the documentation.

My original post was incorrect (I was looking at the wrong material). I have updated it with correct information now. Thanks!