Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

eiszfuchs

11
Posts
2
Topics
4
Followers
18
Following
A member registered Feb 10, 2016 · View creator page →

Recent community posts

You're right, it looks weird, I'm especially looking on the marquee texts on some screens. But it's always this way when the glitchy effect kicks in. That explains a lot. :D

I like options! 😎

OBS didn't act up yesterday, so here you go:


Alright, I finally got my hands on the tech demo (was confused from the new build a few days ago and did a few races before realizing that it wasn't the tech demo).
(By the way, sadly, even in the newest build, the menu runs a poor framerate still, but this time I'm testing on, like, a Ryzen processor, not my 8 year old Macbook. 🙈)

I really like the floatiness of the ships. It's hard to get used to, but getting the turns just right feels very satisfying and I feel the new handling forces me to use the brakes more often (which I normally just don't). I'll try to run a few more rounds later.
Not exactly sure how I feel about the 3D effect compared to the raw look of the non-techdemo build.

Thank you very much for the sale 😭

Still going to pick it up on Steam later for all the extra stuff!

If somebody else comes here and wonders if there has been any progress:

https://twitter.com/impbox/status/1112163168111849472

Was wondering that, too. It has been veeery silent around this game.

Sorry for the delay! Disabling GIF capture does not affect the laggy menus. :(

I'll try that! It doesn't affect race gameplay as far as I can tell, it's mostly notable while using menus.

I reported the crash using Backspace, too: https://itch.io/t/92513/first-feedback-after-1-hour-of-play-time

(1 edit)

I'm not exactly using a "gaming rig" at the moment. I tested the game on a Early 2011 15" MacBook Pro running macOS Sierra 10.12.4 so far. (That's a Intel HD Graphics 3000 512 MB, 2 GHz Intel Core i7, and 8 GB 1333 MHz DDR3 RAM.)
I screengrabbed something, hope that helps a bit: zeug.eiszblu.me/share/vektor-tearing.mov (I was driving like an idiot because I tried to get to the pause menu by pressing Esc which apparently doesn't work haha.)
(Yes, this looks like that even without using a screen recorder.)

The crash also occurs when I remove all characters including the last one pressing X.

About the speed-- I'm a great fan of the WipEout games, and I especially like the Zone racing mode because the speed increases every second and the only thing you have to care about is your agility. So that's why I like me some insane speed classes. :D

(1 edit)

Ahoy!
We just had a lot of fun and totally forgot the time over one hour of play time. We had some minor issues you might find helpful though:

  • The main menu felt laggy and had varying framerates, some screens looked like they had redraw issues. When you opened the menu during a 3-player split screen match, the scrolling text over the lower right screen "smeared" over the screen and everything felt kinda slow.
  • The editor is a bit confusing. I will dig more into it, but what I missed was starting a track from scratch. I pushed all buttons and did not have a clue what I was doing. Maybe I missed a README or so.
  • I've lost two tracks I tried to save because the game crashes when I hit the backspace button on the keyboard. (Like, trying to save under a different name than "TESTTT".)
  • Speed class "S" still felt... a bit slow, actually. And even a friend said that. The overall speed boost between 125 km/h and "S" was quite low. I could use a lot more speed.

But overall, we had a lot of fun! Keep it up! <3