🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

chromewing

9
Posts
1
Topics
4
Followers
17
Following
A member registered 2 years ago · View creator page →

Games

Recent community posts

I appreciate it!  Huttyblue and I are working on updates each Thursday, and today we actually added gamepad support and revamped techno tundra.  

Change the controls profile dropdown in the keybindings menu to "Gamepad" and remap the keybindings to your controller to test it out!  (devlog and more info will be posted by hutty tomorrow)

We are planning to hit kickstarter and maybe greenlight sometime in June!  We post from these twitter accounts to #indiedev and #screenshotsaturday if you wanted to keep in touch:

@ChromeWingDev

@huttyblue

@rocket_theater

Also stick around for a new character coming in a week or so... :)

Hmmm... maybe disregard all of this actually, it might be a mistake in setting Start from 1 to 4 in Null, when instead it should be set to 4 in "Ndu".

Apparently there's an issue with some alienware on windows 10 where if you got your pc with "killer ethernet" installed, it has memory leak issues in the non-paged pool. setting Ndu's Start value to 4 fixed all issues for me.

I'm back with some very particularly interesting information on the matter.

I found out why this happened in the first place...

So this past week, after I changed Null's registry back to the defaults, I discovered an issue that's been happening a long time ago since I first got this alienware laptop. The computer will sometimes come to a crawl, which is totally unnatural, since it was pretty new at the time (and still is). I would check task manager to find that the memory was near 100%, System process taking up most of it, and causing the OS to occasionally freeze for a second, and resume again. Well, now it's been happening again, and naturally I look for a solution to the problem...


that same video I remember finding tells me to set Null's Start registry to 4. That's why this problem happened.

So on the one hand, I get my non-paged pool back to normal, tolerable levels, but I'm pretty sure that will now mess up dev/null for any git related work. Thankfully, I've only had to rely on Unity collab for any projects, but this is just.... weird. Windows 10 seems to straight up have an issue with this and to have to modify the registry to fix it just seems way off. It actually does remove the memory issue though, a long time after I didn't have anymore freezing, but if only there was a better solution than this. I don't really mind anymore now that I know what was happening, but long story short... Windows 10 has got some issues to fix 0.o

Ok, so I just solved it.

I have NO clue how in the world this happened, and amazed at how precisely specific the issue was.

My Null registry was corrupt.

By going into (Windows Key+R) -> Regedit, I navigated to HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/Services/Null.

The Registry "Start" was set to a value of 4... but the value should be 1.

I'm starting to question how that happened. I do recall at one point having to modify the registry to fix my RAM from allocating too much virtual memory, but I don't remember navigating to this particular location in Regedit to do so.

However, all this sounds a bit familiar when I was discovering that sourcetree wasn't installing properly, and it turned into a discovery that git simply wasn't working because it claimed "dev/null could not be found".

This all seems to link up with what the Squirrel process (or whatever the itch app uses to pull from a git repo) was having issues with.

Sorry for the confusion, but at least it's all fixed now.

and most importantly, thanks for giving the effort in helping me with this strange problem. 👍

(Edited 1 time)

doing that gives me a login screen on the app. typing an incorrect password correctly states that the password is incorrect. correct login still triggers the original image of an error "spawn unar ENOENT"

bin folder contents:


unarchiver contents:

crashlog:

Error: read ENOTCONN
    at exports._errnoException (util.js:1022:11)
    at Socket._read (net.js:425:21)
    at Socket.Readable.read (_stream_readable.js:348:10)
    at Socket.read (net.js:308:43)
    at new Socket (net.js:188:12)
    at createSocket (internal/child_process.js:243:11)
    at internal/child_process.js:329:22
    at Array.forEach (native)
    at ChildProcess.spawn (internal/child_process.js:318:9)
    at Object.exports.spawn (child_process.js:399:9)
    at Object.<anonymous> (C:\Users\ifeld\AppData\Local\itch\app-23.4.0\resources\app.asar\appsrc\util\spawn.ts:90:30)
    at Generator.next (<anonymous>)
    at C:\Users\ifeld\AppData\Local\itch\app-23.4.0\resources\app.asar\app\util\spawn.js:7:71
    at __awaiter (C:\Users\ifeld\AppData\Local\itch\app-23.4.0\resources\app.asar\app\util\spawn.js:3:12)
    at Object.spawn [as default] (C:\Users\ifeld\AppData\Local\itch\app-23.4.0\resources\app.asar\app\util\spawn.js:20:12)
    at Object.<anonymous> (C:\Users\ifeld\AppData\Local\itch\app-23.4.0\resources\app.asar\appsrc\util\os.ts:87:29)

EDIT: is there any reason why there'd be any other file located anywhere else on my system that would trigger an error, or is it something about my connection? I still recall this app working before it stopped working, and I still test this with windows defender live scanning off and firewall off.

Yes, still same error when I delete both AppData/Roaming/Itch, and AppData/Local/Itch.

Error: read ENOTCONN
    at exports._errnoException (util.js:1022:11)
    at Socket._read (net.js:425:21)
    at Socket.Readable.read (_stream_readable.js:348:10)
    at Socket.read (net.js:308:43)
    at new Socket (net.js:188:12)
    at createSocket (internal/child_process.js:243:11)
    at internal/child_process.js:329:22
    at Array.forEach (native)
    at ChildProcess.spawn (internal/child_process.js:318:9)
    at Object.exports.spawn (child_process.js:399:9)
    at Object.<anonymous> (C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\appsrc\util\spawn.ts:90:30)
    at Generator.next (<anonymous>)
    at C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\app\util\spawn.js:7:71
    at __awaiter (C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\app\util\spawn.js:3:12)
    at Object.spawn [as default] (C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\app\util\spawn.js:20:12)
    at Object.<anonymous> (C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\appsrc\util\os.ts:87:29)

also, this is what's in the bin folder since the last time I tried doing a fresh reinstall...

(Edited 3 times)


also on occasion, this happens after the app fails to login.




I use malwarebytes, but I don't have it set to scan anything live, and I even tried disabling real time scan on windows defender (windows 10).


EDIT: I should note that at one point, this app worked, then I changed something (might have been an attempt to move the installation location) and since then, reinstallations and "full clears" haven't worked (don't know why windows thinks uninstalling something just means remove some of the files it left since the original install.)

https://gyazo.com/fc59a2423b8f98098db92e4a88c46771

I don't remember what I did, but for a while now I haven't ever been able to sucessfully install the Itch app. I've tried before to clear out the installation to refresh the files (uninstalling through windows control panel still leaves traces in the Local and Roaming folders...) to no avail. It keeps complaining about a connection, so I disabled firewall and it still doesn't work. I've tried investigating myself, but only came to the conclusion that somewhere in the spawning of the unarchiver, it fails to continue.


below is the crash log that windows complains about when I launch the app. oddly enough, the app still technically launches, but gives that screen that I linked above.


any help is appreciated.

Error: read ENOTCONN
    at exports._errnoException (util.js:1022:11)
    at Socket._read (net.js:425:21)
    at Socket.Readable.read (_stream_readable.js:348:10)
    at Socket.read (net.js:308:43)
    at new Socket (net.js:188:12)
    at createSocket (internal/child_process.js:243:11)
    at internal/child_process.js:329:22
    at Array.forEach (native)
    at ChildProcess.spawn (internal/child_process.js:318:9)
    at Object.exports.spawn (child_process.js:399:9)
    at Object.<anonymous> (C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\appsrc\util\spawn.ts:90:30)
    at Generator.next (<anonymous>)
    at C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\app\util\spawn.js:7:71
    at __awaiter (C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\app\util\spawn.js:3:12)
    at Object.spawn [as default] (C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\app\util\spawn.js:20:12)
    at Object.<anonymous> (C:\Users\ifeld\AppData\Local\itch\app-23.3.1\resources\app.asar\appsrc\util\os.ts:87:29)

Hi, sorry for not seeing this, if you make a text file in the game's folder and save it as a .bat file with this in it:

start java -Djava.library.path="./windows/" -jar "Generantis.jar"

It would run the game using your default JVM options. The reason why there are JVM options in place in the current version is to reduce lagspikes and improve performance. Hopefully that works, and I'll probably end up including a batch script in every release so that there's a plan B (and also fine tuning the JVM options.)

Very nice feel and polish! Makes me want to get Luftrausers (never got around to trying it yet)