Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Cant open my world from 1.03 in 1.04 ? is this normal do not want to restart.

(+1)

Not a bug. The release notes say old save games are not compatible.

Yeah they updated that it wasnt there before.