Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Thank you for the detailed help tips.

Originally ran the .exe file from a folder called downloads.  All files were unzipped - 16 files and 3 folders.   Moved to the desktop and no difference.  Tried from C:\PixelCNC and no difference.  If I run as administrator it asks me if I will allow Pixel CNC to make changes.  When I do not run as adminsitrator I do not get that splash screen.

  

I am working in native windows - not sure what those other things are so I am sure I am not using them.

log file is very long but the config.dat file does load when run from the desktop and from  C:\PixelCNC

  first few lines of log file - I do not know how to attach the file to this reply.

0.017  
0.017  [ PixelCNC v1.43a Trial 64-bit  - Jul  1 2020 ]
0.018  [ Charles Van Noland - http://pixelcnc.deftware.org ]
0.019  
0.019 exe: C:\PixelCNC (64-bit)
0.020 user: C:\Users\Lunty Laptop\AppData\Roaming\Charles Van Noland\PixelCNC
0.021 log: 201116-213231
0.022 --- initializing ---
0.022 configuration...
0.022 config_init: default version #143
0.023 loaded 5.258kb from "C:\Users\Lunty Laptop\AppData\Roaming\Charles Van Noland\PixelCNC\config.dat"
0.025 LOADED CONFIGURATION:

did get the message that I was using th trial version and my 20 minutes was up 

I run Bit defender, Malawarebytes and Hitman  for anti virus software.

Does not show up in my APPS for Windows 10 so I don't think it gets installed. 

Screen shot of what I get when I try to install.


I'm pretty sure your antivirus software is blocking PixelCNC (which is an "unsigned executable") from accessing its own files though a peek at the complete log file would give more information. I don't think all three are responsible, and that it's only one of them that's the culprit - possibly HitmanPro which is meant to prevent ransomware from accessing and encrypting your files - by simply blocking all unsigned executables from accessing anything. You should be able to add PixelCNC to a whitelist or "allowed" list of programs.

Before you do anything go ahead and paste a logfile to http://www.pastebin.com and paste the link it generates here so I can view the log in its entirety. If PixelCNC is able to generate a config file and a log file I can't imagine it wouldn't be able to at least read its font image files but something appears to be preventing it - or preventing it from utilizing the GPU properly.

No, PixelCNC does not yet "install" itself, not until we've reached the beta phase of development. If you ever want to remove it you simply delete the PixelCNC folder and any shortcuts to the EXE you've made.

Here is the link for the log file.    https://pastebin.com/QWp2xTtj

looked at Hitman and could not find where  to add to a list of allowed programs

(3 edits)

Great! Alright I'm seeing exactly what the problem is - PixelCNC isn't utilizing your GTX 1050 but instead the Intel HD 630 and encountering out-of-memory errors while trying to load up the UI text fonts.

I'll have to write some code in there to let the user choose which one to use if there are more than one - for now you should be able to tell Windows to force PixelCNC to use your Nvidia GPU instead of your onboard Intel HD by following the steps in this article: https://pureinfotech.com/set-gpu-app-windows-10/

What's bugging me is that your Intel HD 630 should be plenty capable - it's new enough and supports all of the required functionality but for some reason it won't let PixelCNC allocate any space on it for rendering anything (specifically reporting OUT OF MEMORY every time a texture of any kind and of any size is being created). I'd like to try and figure out what the situation is there but for now you should at least be able to get up and running if you force it to use your other GPU.

EDIT: You also might want to check that your monitor isn't plugged into your onboard graphics. Forcing Windows to use the other GPU won't work unless your monitor is plugged into it - rather than your motherboard. If your monitor has been plugged into your motherboard this whole  time then you haven't been using your GTX 1050 for anything yet. You shouldn't have to force PixelCNC to use the other GPU if your monitor is plugged into the Nvidia one, all programs should automatically use it for hardware rendering.

Did some more experimenting:

1.  Unplug laptop  from USD docking station

2. Load PixelCNC - loads fine on laptop.

3  Plug laptop back into USB docking station - second monitor (BenQ) comes alive and there is the PixelCNC program.  Seems to work - just tried a few menu selctions - did not do any actual work.  Can drag window between monitors.  So I have a pretty easy workaround to get the program onto my bigger monitor.  Will go with that.  

I posted the latest log file to Pastebin.  Here is the link https://pastebin.com/GdQafMwb

Looks like I was successful in changing the GPU but had to do it in the NVIDIA Contol Panel.  Changed ita globally and also for PixcelCNC.  Not sure why it still shows as the Intel HD for the laptop and USB3.0dual display for the BenQ monitor when I look at the praphics settings in Windows.

I am thinking the USB docking station is the thorn in the side.  I have not tried connecting the BenQ monitor directly to the laptop.  Another day perhaps. 

Glad to hear you were able to make progress working things out. The log file indicates that you're cooking with gas now on your Nvidia GPU :)

It didn't occur to me you were on a laptop until I looked up your exact CPU so you likely only have the one video output port on there. I had it in my head that you were on a desktop rig with the Nvidia GPU plugged into the motherboard adding video outputs. I've seen instances where people with a decent GPU in their rig using the onboard graphics because they had plugged their monitor into the motherboard instead of their GPU - so I was thinking maybe that's what might've been the situation you were dealing with but it still wouldn't explain why the onboard Intel HD GPU wasn't able to run PixelCNC properly because it should be completely able to run it just fine - albeit a bit slower.

As a new user test-driving PixelCNC please feel free to share any feedback, any issues, ideas, suggestions, etcetera that you have. Everyone's input is valuable. A lot of great suggestions have culminated in what PixelCNC is now today and what it will be with v.144's release soon.

Getting to beta has been the main focus as of recent - which entails implementing the rest of the planned list of features. Once PixelCNC is in beta there will be a bit of a gear-switch taking place and we'll be working on learning materials such as tutorial videos and the such, so keep an eye out over the coming months. Any significant developments will be conveyed via PixelCNC's automatic update system - so as long as you at least run it once in a while you'll be apprised of the latest happenings as updates are released.

Thanks for your interest in PixelCNC!

Did some more testing this morning.  PicelCNC will run on the Intel HD GPU as long as I don't have my USB dock plugged into the laptop.  So your program works as you expected.  It is my hardware configuration - USB docking station and second monitor.

Next quetsion - how do I load an image.  I know I am missing something simple.

Thank you

That's great news :D

First I'd suggest setting up your project's 'canvas' which is the area where you can create and design your project as well as the volume within which toolpaths will be able to generate. There are four buttons at the top-left, beneath the menubar, which let you go between the four interface "modes". The default mode is for editing the canvas. In that mode you can click "Canvas Properties" to change the size and resolution. You can always change it later but I like to set it up at the beginning of creating a project.

From there you can click "New Layer" just beneath the "Canvas Properties" button, and either create a new editable blank layer or load an image/vector/model as a layer. Each layer "type" allows for different editing opportunities. Paths-layers don't directly affect the canvas and are for generating layers that do have a physical effect on the canvas. There is a lot more detailed information about everything in the User Guide which you can access via the Help menu.

Let me know if you have any specific questions about any of the buttons and functionality.