Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

The Linux-Version is completely broken.
Graphics are glitchy (missing things) and you cant complete even the first scenario, as you cant put leaves on your plant (just an example).

I tried the windows version in wine - this works, but has a massive frame rate drop when putting your first animal (~1 fps).


Tested the Linux version on 3 PC's with 3 diffenrent distributions (LFS, Ubuntu 18.04, Debian 7)

The same for v7.13 and v7.15

Hi Sebastian. First of all, thanks for reaching out and sorry to hear you have so much trouble with the game; I would totally understand if you would request a refund. 


About your Linux problems: there must be something special going on in your case because dozens of Linux players have already completed the game with no problems. One thing I noticed is that the draw distance for body parts is extremely short for the lowest quality setting, also in the editors. This will be fixed in a future patch somewhere in the next few days... but for now could you try a higher quality setting to see if that improves things?


About the frame rate drop with animals in Windows: I discovered today that it is possible to create animals that give problems with the animation system, resulting in the game basically becoming unplayable: it's a combination of two types of feet and very thin animals. Perhaps that's the problem for you too? This will also be fixed in the next few days.

No, i don't want a refund - it's an early access game. And i love the concept of it!

I tried v7.17 today on 2 Linux machines - still the same problem. I tried any graphic options and resolutions

Also, i notices that some stats aren't right. For example: the temperature on the first island is 5950°C. Also the stats of leaves etc. are very different from the windows version (all have 5 suns, etc.).


For the windows-version, it was exactly the problem you described - it works fine with all other animals.

Wow in that case thanks for the trust and the bug reports! Really appreciated :). I just tried to reproduce your stats problem on Linux with v7.17, but no luck. I think your installation must have trouble reading the asset bundles, but I'm unsure how this could result in weird stats rather than just a crash.


So we now have two Unix problems (glitchy graphics and glitchy stats) that I cannot reproduce :(. If you have some time, would it be possible for you to send me a screenshot of the problems, and the error log? Can be found at "~/.config/unity3d/Wessel Stoop/The Sapling/"

(+1)

Just a thought: Old Unity engine versions had problems with non-English locales, often leading to completely random problems. Could you try to start the game by prepending `LANG=C LC_ALL=C ` and check if that changes something?

THIS!!!

All problems with the Linux-Version are solved now!
Even the problems with missing graphics, flickering and wrong stats.

Thank you very much for this tip.


@Wessel Stoop:

You should put a starter with "LANG=C LC_ALL=C ./the_sapling.x86_64" in the Linux-package.

Wow, unbelievable, thank you so much ifo and SebastianPetters... if there's anything I can do for you to thank you, let me know. There will be another patch this week or next week, I'll make sure this is included. 

You already did something for me - releasing a good game for Linux ;-)