Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Mixolumia

Entrancing musical falling block puzzler · By davemakes

Bug Reports Sticky

A topic by davemakes created Aug 07, 2020 Views: 433 Replies: 22
Viewing posts 1 to 9
Developer

Did you find a bug? Let me know! Please post

  1. Which platform (Windows PC or Mac)
  2. What you were doing (steps to reproduce the bug if possible)
  3. What you expected to happen
  4. What happened instead
  5. Additional details/screenshots if necessary
(1 edit)

Ah, um, I think the image is self-explanatory, but
I'm not sure if my maths class were incorrect, or 1068+248+290+93 does not necessarily equal 4.5 million?
In other, less joking words: Total Blocks Cleared doesn't match nowhere near the sum of individuals for some reason. Played three Marathons, two Endless [but left one immediately], two Rush and one Intense. I'm playing on Windows 10, and any other Total doesn't look off at all, just this one.


Developer

Thanks! Just a sloppy mistake on my part, will update with a fix sometime this week.

Hi Dave, loving the game, got a minor sound bug for ya

1. Windows 10 PC

2. Playing through my laptop hooked up to the TV with an HDMI cable (set to second screen only) 

3. Sound and music refuses to go through to the TV

4. Sound and music plays through laptop speakers instead

Developer

I ran into this issue on my Intel NUC and in that instance I think it may be some conflict between the Game Maker engine and Intel's drivers. I'll investigate this and do my best, and any info about your laptop hardware you can share would be helpful. I may wind up pinging the Game Maker people about this one. Sorry for the trouble!

Developer

Quick update: this has something to do with the way Game Maker switches to fullscreen mode. The game is currently set to go to fullscreen when it's opened and then potentially flip to windowed depending on the user settings, but if I disable that and the game launches in windowed mode, there's audio. It goes silent as soon as I toggle fullscreen, though. Will continue to work on this and at the very least the next update will let us play on our TVs windowed, hopefully.

Developer

Just pushed update 1.0.4 which has a bit of a bandaid on this until I can figure out the root of the issue. If you go into settings, turn off fullscreen mode, and then restart the game, you should be able to play with audio over HDMI. You can manually stretch the game window to your screen size. Sorry it's not ideal, you'll probably still see the window chrome and taskbar, but I'll keep trying to figure out what's going on with Game Maker and these audio drivers. At the very least, I might try to figure out how to do a "windowed fullscreen" mode to circumvent this issue.

1. Windows 10
2. Entering Rush mode with precise timing enabled
The timer only increments in seconds. The milliseconds are  displayed as 000 throughout

Came across the game through the Twitter thread of development & love the concept. Keep up the good work

Developer

Oh, god catch! I'm treating the rush mode timer a little differently because you can *technically* have a game that lasts a couple extra seconds if a big combo keeps going after the timer runs out, but it was weird to see it end at like 2:01 occasionally. I must be rounding the number and forgot when I implemented the precise timer.

Developer

Got a fix in the new 1.0.4!

(1 edit)

Hello!

With a German keyboard layout the Z and Y keys are switched in comparison to an Englisch layout. It would be good if
A) there is a way to change the input key(s) or
B) detect the layout and switch the keys autmatically.

I’m on Windows 10 and MAC OS 10.15

Cheers

Developer

Guten tag! Button remapping is the next big feature on my todo list, and I'm sorry I wasn't able to finish it before release. But it's important to me, and I know a lot of people need it. In the meantime, I suggest trying something like AutoHotkey. I'm sorry for the inconvenience!

While in the pause menu during a game, pressing start again on the gamepad just sorta "refreshes" the pause screen instead of backing out of it. It's a minor nuisance, but doesn't impact the experience in any critical way.

Developer

oh, good catch! thank you!

Developer

Just pushed 1.0.4 with a fix for this!

My laptop uses Windows 8.1.

At some point, after playing a round of Rush with one of my custom color palettes selected (Tensity, my second one, which is one palette before the last one in that file), I switched over to Relaxed, selected the default music, then pressed Tab a few times wanting to pause the game as soon as it starts while I go do something, and suddenly, my mouse appeared in the middle of the screen doing the "I" thing like it's hovering over text (I later discovered this was because of the error handler appearing behind the game) and the game stopped responding.

I pressed Alt+Tab a few times, to no avail, then used Ctrl+Alt+Delete to open my task manager, and, well, the game itself was minimized (showing a white screen whenever I hovered over the preview with my mouse). I decided to close the game via hovering over it on the toolbar at the bottom of the screen and clicking the little red X, which closed both the game and the error handler.

Ultimately, I think what may have happened is I accidentally attempted to pause the game while it was still in its startup sequence, but I don't know the first thing about this sorta stuff. o3o

Weird Linux build problem: some of the time, game works great. Some of the time, everything seems fine and normal in the menus but when gameplay starts, pieces are shoved to the right immediately. I can still tap Right and Left and the screen does the little 'bump' animation, so it's registering those normally, but at most I can bump the piece left for just a moment and then it hugs the right wall the rest of the way.

Keyboard only, no gamepad / joystick of any kind plugged in.

oh and I'm using Ubuntu 20.something if that helps at all

(1 edit)

Hello! Been loving this game so far and wanted to try it on a different device (Windows PC), ended up restarting the computer because when I tried switching off the fullscreen my screen became black and unresponsive. Now it won't open and this error appears - it may be something with my device but I'm not sure? I've redownloaded the game it and still came across the same issue


Developer

Whoah, that's a weird error! Looking at it, it might be that your key bindings config file may be corrupt. Try going to this folder:

C:\Users\your name\AppData\Local\Mixolumia

and delete the files gamepad_config.json and keyboard_config.json (and their backups), then start the game again and let me know what happens.

Oooh yeah that fixed it! Thank you!

Developer

Oh whew! I have no idea how that happened but I will have to build something into the next update to check for it so it does something better than just crashing. Glad it worked!

I had changed a key binding before trying the fullscreen so maybe it was closed mid-save!