Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

ISSUE (28th July 2020) Linux version: Missing libpng12.so.0 (file not there -- but you do have a libjpeg.so.8)

A topic by poison.ivy.maze created Jul 27, 2020 Views: 117 Replies: 3
Viewing posts 1 to 3

Might I have an old version? I downloaded what was available in the itch.io zip file.

Trying to run game:

[me@computername]$ bash tanglewd_linux_64.sh
./linux/tanglewd_linux64: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Checking the permissions in the main folder (just in case):

[me@computername]$ ls -l
total 15944
drwxr-xr-x 2 me me    4096 Aug 17  2018 bin
drwxr-xr-x 2 me me    4096 Aug  4  2018 fonts
drwxr-xr-x 2 me me    4096 Aug  4  2018 linux
-rwxr-xr-x 1 me me     126 Aug 14  2018 tanglewd_linux_64.sh
-rw-r--r-- 1 me me 7895552 Aug 17  2018 tanglewd_win_32.exe
-rw-r--r-- 1 me me 8403968 Aug 17  2018 tanglewd_win_64.exe
drwxr-xr-x 3 me me    4096 Aug 14  2018 tanglewood.app
drwxr-xr-x 3 me me    4096 Aug  4  2018 textures

So I check the files and permissions in the folder with all the .so files...

[me@copmutername]$ ls -l./linux/
total 19796
-rw-r--r-- 1 me me    81040 Aug  4  2018 libbsd.so.0
-rw-r--r-- 1 me me   363264 Aug  4  2018 libjpeg.so.8
-rw-r--r-- 1 me me  1111576 Aug  4  2018 libSDL2-2.0.so.0
-rw-r--r-- 1 me me    76160 Aug  4  2018 libSDL2_image-2.0.so.0
-rw-r--r-- 1 me me    55520 Aug  4  2018 libsndio.so.6.1
-rw-r--r-- 1 me me  1566440 Aug  4  2018 libstdc++.so.6
-rw-r--r-- 1 me me   375168 Aug  4  2018 libwebp.so.5
-rw-r--r-- 1 me me    14488 Aug  4  2018 libXss.so.1
-rwxr-xr-x 1 me me 16612760 Aug 16  2018 tanglewd_linux_64

I would really love to run this game. Thank you for your time.

It's basically an old library, I'm just not sure how to install it either. 
The command should be as follows

sudo apt-get install libpng12-0

Thing is, like I said this library is old and may not be found by your system. Not even Wine saves this one because the graphics get messed up. At the very least it comes with a Mega Drive rom version too so it's the one saving option for us Linux users.

If anyone knows how to work around forcing installation of older libraries, please do elaborate.

Hi Yanazake, are you a dev with this game?
I might have anticipated that the demo game would be complete enough to run without installing a 3rd party ROM emulator (for which is how I'd assume the TANGLEWD.BIN file in this itch.io repository to be).

I see that you're saying that it' not about the code in

./linux/tanglewd_64

but the way that Unity refers to .so files on the user's system?
And while it is possible to include .so files with the game itself, in this instance for some opaque reason the file is being scanned on the user's computer?
... for a game installation, I find that very strange. Isn't the point of a game package manager like unity to include all the code to make the game run?

hmmm... I did some digging on this.
I see people writing in different parts of the internet to use a PPA. And I'll tell anyone here listening -- one VERY important lesson: NEVER run a PPA for a piece of code from a source you do not personally trust such as a close friend or coworker.
People will tell you "you need to run this to get this other thing to work" -- and "look here's the source, see? it's fine!" And if you accept the PPA, you also accept all updates for that piece of code. That's what package management is after all; but since it's a PPA, updates aren't part of a repository's web of trust that can veto bad actors. The first update can be benign, and the second one, but a third update can contain a hidden payload from the source who's a black hat in disguise. There's no possible way you can remain vigilant all the time.
Some good news, though: I found a reference to a Debian package at

dpkg-deb --info libpng12-0_1.2.54-1ubuntu1_amd64.deb

^worth checking out what the repository has to say before thinking of installing it.

However I run arch on this laptop, so my package manager (pacman) returns no such libpng12-0 package or as a file within a package when I search for it.

No, I'm not a dev, simply another player that does like to mess with things to make them work in the weirdest places since I got a PSP.
That said, also no, the BIN file is a genesis/mega drive ROM because this game was originally made to be able to run on the system. Just like Pier Solar has a genesis compatible version.

About the missing library not being included with the game itself, I believe it's a thing about linux games in general. They MIGHT install additional libraries for you, (specially if it's steam stuff) but more often than not, they won't. When they don't work, you need to check for log or launch them from a terminal to know what kind of error it spits out, find out how to install what it needs, restart if necessary and try again. It shouldn't be as tiring as "missing .xna package, install from microsoft site" but it feels more tedious or like it is extra work because we're likely not used to it.

I get what you mean about "don't get extra packages unless you trust them" but I personally don't mind it much. I've used way too many sketchy software in windows to be worried about everything I'm getting on linux. I dunno, it just feels safer?