Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Luna Engine MV

A script that modifies RPG Maker MV UI easily · By Archeia

Issues with showAnimationOn and the Battle Status Hud...

A topic by ZeroBeat032 created Jul 19, 2020 Views: 76 Replies: 2
Viewing posts 1 to 3

So I have a frontview battle system and I've been trying to get it to show animations on the hud. so I used showAnimationOn on a certain lunatic item of the hud and everything worked fine.  But as soon as I had more than 3 party members in battle, an error would occur. I determined it was showAnimationOn that was causing it... but no matter what I attach it too the same error pops up and even migrating bits and pieces of the code to blank projects causes the same issue.

I'm not exactly sure what to do about this one as this isn't an error I've really seen before.  I couldn't find much googling anything either unfortunately.  If anyone has any suggestions on what could be the issue, I'm all ears...

If you check the documention, "ShowAnimationOnHud" is a setting only for the general config that allows the game to show combat animations for skills and etc on the hud. You should not be using it on specific items in the UI. 


If you check the documentation again, the only valid times for when animations play is:
"onSceneEnter" : When the screen appears
"onItemSelect": When selecting an object/item/command etc
"onItemUnselect": When an item/object/command is unselected

And two others we forgot to include:
"  onComponentShow:" When a window appears (eg, skills window)
"  onComponentHide:" When a window disappears

ahh ok. the ONLY reason I thought this was a possibility was because in one of the base demo's, there was an example of showAnimationOn: ActorFace... ActorFace was a lunatic item in that specific set of item. and it worked with 4 party members active. so I figured I'd be able to do something similar, but I guess not? I have my actors on the screen as UI items and was trying to get the combat animations to show on them. So yeah I started wondering why it wasn't working like the one from the Early Access Base Project. But If it's generally not supposed to work that way, then that's ok.