🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

0.35 Update not working

A topic by Ajax1983 created 35 days ago Views: 85 Replies: 9
Viewing posts 1 to 3

So I saw that the game has been updated to 0.35, but none of the features are available in the game. I started a new map, but nothing. Am I missing something?

Developer

Things to check:

  • Title screen says InDev 0.35 - 5/22/2017
  • Create a new game, grab and place the crafting table. Open up the crafting UI. You should see the new foods along the top row - and the Comms Tower, Power Switch and Repair Drone Base are all down near the bottom (scroll down).
  • Options Menu should have sound and music volume sliders on it.

Nope. Nothing. The game won't even launch now.

Developer

That's weird that it'd suddenly start crashing on launch on a machine that it was working on minutes before.  Could try deleting the "settings.json" file to see if that makes it work.  (Although the same crash issue could potentially return).

Have you tried re-downloading a fresh copy of 0.35?  Give your machine a reboot? (On some of my older machines, sometimes Java applications would suddenly all suffer from performance issues etc, and only rebooting would clear it up).

If those things don't work - and to really figure out what's going on, I'd need a copy of the log file. The easiest way to get that is launching the game through the Itch Desktop App.

Install and try and run it through the Itch App, let it crash... then on the game's page: 
Right click "Show local files" -> Advanced -> View logs
Send that file or copy/paste the text into an email and send over to me cairn4games@gmail.com

(Screenshot of that stuff)

If you're using Windows, and don't want to use the Itch app, then you can also follow these steps so that it outputs the debug log into a console window at launch: https://itch.io/post/125800  Just make sure to select it all (or as far back up as it'll let you) when you go to copy it into an email.


Okay, I got the game to launch by rebooting Itch and reinstalling the game, but it won't update to 0.35. I also can't download the new version. It's asking me to purchase it again. Am I not updating the game properly?

Developer

If you've installed the game via the Itch desktop app, it automatically installs the latest version.

Click the "Check for Update" button - make sure you're launching the game through the Itch app and not from somewhere else on your machine.

What version of the game does it say it's running? and what OS is it on?

Yeah, I'm launching it via the Itch app. When I click on the "Check for Update" button, nothing happenes. I can launch the game, and on the title screen - bottem right corner - it says : InDeb 0.34.2 - 3/28/2017. Above that it has a button labelled "Update Available". When I click it, it sends me to the website to download the latest version, but I'm reuqired to purchase the game, which I've already done when I first bought the game. So I'm not sure what's going on now.

Just an update. I am now getting 0.32.1 as the InDev version, and it won't update to the 0.32.2 InDev version.

Developer

> When I click on the "Check for Update" button, nothing happenes.

That could be a bug with the Itch app if *nothing* is happening... but I have one more idea to try: Right click on the Version number in the Itch app (right above the "Check for Updates" button...

-> Advanced -> Revert to Version -> Select the top one in the list, should read something like "#30996 - 23 May, 2017..."  (that's the latest 0.35 one).

After you click it, it'll close the popup window and you should see the game start downloading.  Then try launching again when it's done.

So the other behavior you noticed (Clicking the "Update Available" button from within the game, and being shown a browser page to buy the game again) ... is probably just because you're not logged into itch.io in that particular browser.  On one of my computers, using that button always opens Chrome for me, even though my default browser is Firefox.

Sorry this has been such a pain. Not really sure whats going on.

Where did you suddenly get the 0.32.1 version?  that's way older... 

The 0.32.1 issue happened after I tried what you just suggested, which was to attempt to revert to a different version. I'm 99% sure that I selected the 23 May 2017 version, but now that version doesn't even appear. Maybe I selected a wrong version and ended up with 0.32.1, but it doesn't explain why the latest version is not showing up, does it?

Also, don't stress about. I'm sure there's a solution :)