Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Mac Saving Issue

A topic by GrayGryphon created Jun 08, 2020 Views: 125 Replies: 8
Viewing posts 1 to 4

When I tried to save the game on a Mac, I got this error:

Do you have any idea when it'll be fixed? I lost three chapters worth of progress because of this.

Developer

First I've heard about it, I'll look into it.

I got a similar error when I hit "escape" on the options page.  

and also, it wouldn't let me save. Just beeped at me. (I'm on a Mac too, Mojave 10.14.6)

Developer

Quick question, are you downloading and unzipping the files, or using the Itchio app?

Ahh, it was just downloading and unzipping. I just tried to test it via the app but using the app I get a different error on launch.  


This error happens every time I try to launch the game. I uninstalled and reinstalled and still get the error when I launch the game. 

I actually got that error at the same time, I assumed it happened because I was trying to save and the reaction was delayed, since it actually mentions a "save" folder.

Anyways, I just tested, and yeah, actually the error happens when exiting the options menu, not when trying to save.

Developer

Two questions, GrayGryphon. What Mac version are you using? And are you downloading and unzipping the files, or using the Itchio app?

macOS Sierra, version 10.12.6. I downloaded and unzipped the files and launched from the unzipped folder.

i've had the exact same issue on my mac, too, mojave 10.14.6. i tried it multiple times, and it always crashes whenever i leave the options menu. i'm no programmer, but as far as i can tell, it's just that it tries to save the options to a read-only file that should be read & write.