Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

[Solved] SuperTextMesh in Canvas fails to draw on scene load

A topic by Jonathon Yule created Apr 16, 2017 Views: 368 Replies: 4
Viewing posts 1 to 5
(1 edit)

I just implemented scene loading into my game and it has caused a bug with SuperTextMesh. When I present the scene, it is supposed to have text on canvas visible from the start. SuperTextMesh as objects in scene present normally. I have tried forcing a Rebuild in multiple places including Awake, Start and even frames past Start but nothing will show unless there is user interaction with the buttons.

Any ideas on what to do next?


Are you using async loading? Another customer was having an issue with this, and I was hoping to properly fix it in the next update. The temp solution I told them was to use FindObjectsOfType() and call Rebuild() on all of the meshes, but that's weird that it's not doing anything for you. The cause probably has something to do with the OnSceneLoaded delegate on STM.

Does it still happen with non-UI text? That might help me narrow down the cause.

Yep I'm using async loading. Non-UI text works perfectly on the scene load


UI text has given me so many issues, it's frustrating to troubleshoot... Could you send me a .unitypackage with an example scene to my support email? Either the one on STM's store page, or the one on my website will work!


Solved this in v1.6.2!! Sorry this took so long, I never had a good repro of the problem until recently.