Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Does not open on OS X 10.15.3

A topic by NNNontendo created Mar 07, 2020 Views: 98 Replies: 13
Viewing posts 1 to 5

Not an issue of security, it just doesn't open.  Even when I command-click on it to open the package internally.  Still, won't open.

Developer

Damn! Let me ask my college about this, he might have a solution for you...

thanks!

Developer

i guess that v0.2 (i've just released it) has the same issue...

Yep, still not able to open, tried both methods just like the last time.  Sorry it took so long for me to reply - had stuff to do/had to sleep :D

Developer

Hello NNNontendo,

Sorry for the delay, did you tried to type in the terminal:

sudo spctl --master-disable

Then going to your security panel and check "Allow apps downloaded from..." to  "Anywhere"?

I found the solution here: https://www.macworld.co.uk/how-to/mac-software/mac-app-unidentified-developer-36...

I hope this might helps you...

Howdy frankiezafe!

No luck, I did input that master disable code, and it's still the same issue.  Maybe OS X is just being fussy?  Even Chrome makes me "accept" the file, unlike other files I download.  I hope this will eventually get fixed, as I can see it being a very nice tool for album cover art, amongst other types of digital artwork!

NNNontendo

Developer

hello,

it's really hard for me to fix this without having an osx in front of me... thanks for trying!
i'll let you know asap i find a solution

cheers

no problem at all, thank you for working with me 馃檪

(2 edits)

@NNNontendo With the new MacOSX securities, it prevents starting programs from unknown developpers.

One thing you can do is download the latest version of Laces, and do

chmod +x ./Laces.app/Contents/MacOS/Laces

from the folder where you unzipped the archive.

Then you should be able to launch the app, get a message informing you that the developer hasn鈥檛 signed the app, and still open the app.

Thanks for the help!  That didn't work either.  I'm really not hard-pressed to get this application to work.  Although it's very nice, I'm a graphic designer already, and can do most of this by hand quickly (after 18 years of making clipping paths, 13 of them spent clipping around 100-tooth saw blades, 50-tine rakes, bricks, and other textured items).  Here's pics of what I got, though.



option-clicking to open the file and access the app internally


Hello

Sorry, the chmod +x command screenshot you posted shows you have run the command from inside the Laces app folder. If that is the case, you should run it it like this:

chmod +x Contents/MacOS/Laces

Can you try this?

OK!  That works - thank you.  Will this be changed in future updates so those who do not know to do this will be able to open it?

Developer

xuv will test a manipulation on the downloadable version, but we have no guarantee that it will work
wait and see...