Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Mission: It's Complicated

To stop a cosmic evil, you need to get some superheroes to fall in love and kiss… or maybe just become best friends. · By Schell Games

Bug: Broken on Vertical Monitors

A topic by Romiress created Feb 17, 2020 Views: 165 Replies: 6
Viewing posts 1 to 6

Hey there! The game looks super cute and I'd love to play it, but unfortunately that isn't an option for me right now. I'm running on Windows 10 and I have a three monitor setup, with my primary monitor being vertical. When I launch the game, it launches in windowed 1080x1920 (not the standard 1920x1080). There's no way to resize the window, there's a huge black space at the top and everything is stretched out, and while I can access the setting menu, the confirm button is clickable but does nothing.

Any advice so I could play would be great!

Oh no, that's no good! We might not have tested the game on vertical monitors >.< I'm not seeing an obvious way to change the startup resolution, but hopefully QA/engineering folks can reproduce this tomorrow and come up with a fix.

In the mean time, can you see if it's running in windowed mode or full screen? You can't change the resolution in full screen, but in windowed you should be able to. Then the confirm button might work? (Also, if you can see it, it would probably be useful to see what resolutions it's filling into the dropdown.)

I dug a little deeper. If you want to get hacky, you could go into: 

C:\Users\[your username]\AppData\LocalLow\Schell Games\Mission - It's Complicated

...and edit the globalgameState.json file. 

What's the "_resolutionIndex" value you're seeing? 7? If it's not 7, try 7! If there's a section that says "_fullscreen": true, try deleting it to get you in windowed mode. Maybe that'll behave better?

Anyway, this is all goofy and not a real fix, but idk maybe you're dying to play? If you don't feel like messing with this I understand, hopefully we can get a fix in soon!

It's running in windowed mode by default. When it first launched it seemed to go to  My settings are showing as 1280 x  800, windowed. There's no way to change it, since while I can pick other options, the confirm button isn't working.

The globalgameState doesn't have either of those options. As follows:
> {"$id":"1","_systemStates":[],"_lastSaved":"2020-02-17T05:47:48.9728264Z","_gameTime":{"$id":"2"},"_textBanks":[],"_userIdentifier":"cc02246a-4002-4e9b-bb39-875f03163c50"}

Here's what shows up on my main monitor when it launches (the splash screen for the company, I should note, displays just fine): 

Let's try adding it in there? Like so:

{"$id":"1","_systemStates":[],"_lastSaved":"2020-02-17T05:47:48.9728264Z","_resolutionIndex":7,"_gameTime":{"$id":"2"},"_textBanks":[],"_userIdentifier":"cc02246a-4002-4e9b-bb39-875f03163c50"}

It's real weird that the confirm button doesn't do anything, but maybe it's failing to change the resolution bc something about a vertical monitor is throwing it way off.

And that worked! Thanks a ton. Hopefully the bug can get hammered out, but this worked for me so I can start playing.

Yay! Meanwhile, we've repro'd the bug, including the settings buttons not working, so once we get some engineering time hopefully we can fix it for others. Thanks very much for reporting it, and for trying out the hack fix -- knowing that fixed things is really helpful to know.

I hope you enjoy the game!! ^__^