🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Maxwell doesn't work with Etherdream 2 DAC

A topic by donavanbadboy created 168 days ago Views: 262 Replies: 11
Viewing posts 1 to 9

I purchased Maxwell because it was supposed to be compatible with Etherdream DACs, I have an Etherdream 2 DAC and Maxwell does not work with it.

Please advise, regards, Dan.

Developer

Are you using the Ethernet connection of the Ether Dream or the new USB connection? I don't currently have an Ether Dream 2 yet - but according to the Developer it should be directly compatible with the Ether Dream V1 as long as you are using the Ether Dream port.


If you are using the Ether Dream port, and it is not working, I will indeed investigate ASAP!

I am using the ethernet port. Maxwell sees the Etherdream 2 DAC, but there is no output from the laser projector. The software seems unstable too, it crashes if you try to disable the DAC after enabling it.

Developer

I should be receiving my Ether Dream 2 this week. I have discussed this with the developer of the ED, and we feel like it should just work - but when I get my unit in, I will be able to fully test and hopefully get to the bottom of the issue.

I've tried upgrading the firmware on the Etherdream 2 DAC but the issue remains.

I will explain exactly what I'm doing in Maxwell to re-create the problem...

1) Open Maxwell app

2) Load a preset file and select a preset

3) Click the Power button

4) Click ON/OFF in the DAC selection section with settings showing:

* DAC TYPE: EtherDream

* DAC INDEX: 0

* DAC PPS: 20000

Expected result: laser should output as per preview window

Actual result: Laser seems to output something for a split second then stops

I suspect that the Etherdream driver DLL included with Maxwell is incompatible with the Etherdream 2 DAC because I had similar issues with LSX until I upgraded to the latest version which included a newer Etherdream driver DLL.

Developer

donavanbadbiy

Please send me an email to:


lightspeedjohnny at gmail . com


I have a beta version for you to test out which should address the Ether Dream 2 issue.

Just adding a reply here so you'll get a notification. Having the same functionality issues as described above, it'd be great to get a hold of that beta w/ etherdream v2 functionality. You can email me at my username at gmail.com . Thanks!

I have the same problem. Just purchased this, but it will not connect to the laser via the etherdream2. Is the beta released yet?

Thanks!

Developer

The 1.5 version of Maxwell should have full ED 2 functionality on Windows.

If you are seeing an issue, please copy and paste the output of the Max Console window in an email to : lightspeedjohnny at gmail . com

For future reference, here's what was wrong. A) I was running the 'sitter.exe' included in the etherdream v2 downloads to keep track of ILDA activity, and it was using the same port as Maxwell is configured to use, and thus was blocking Maxwell (Fix: Quit 'sitter.exe' before starting Maxwell) B) I think there were issues relating to having 32 bit Max installed on my system, but not 64 bit Max installed. The combination of uninstalling Maxwell, installing 64 bit Max, and reinstalling Maxwell fixed the 'Error 193 loading external jit.maxwell' message. This shouldn't technically happen because Maxwell is a packaged standalone with it's own copies of the Max libraries? But it's what worked for me. 

(Edited 1 time)

I am also experiencing problems connecting Maxwell to EtherDream 2 on OSX:

The program seems to run ok, I can load and run presets and the animations are displayed on the preview window. 
Everytime I turn on the power button  in the Laser DAC zone inside the Maxwell UI, the following message is displayed in the max console:

"there was a problem connecting to your DAC"

Already tried with :

DAC INDEX: 0 and 1

DAC PPS: 20000 and 30000

always gives the same error.. please help.

oh boy!! finally I've made it to work...