Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

FPV Freerider not seeing my Taranis

A topic by misherman created 88 days ago Views: 240 Replies: 5
Viewing posts 1 to 3

I purchased FPV Freerider over 3 years ago and it's always worked great, Last night I was running it with no problems for about 10-15 minutes and it just stopped - the quad will not take off when I raise the throttle. I have tried everything simple - rebooted the app, rebooted my PC, rebooted the Taranis. Tried 3 different USB cables. When I connect the USB and select USB Joystick I  get the same 4 tones as always. But no response to the sticks when I go into the app. I tried recalibrating the sticks in the app (Taranis shows stick movement as normal), but nothing happens on the 1st calibration page - the dots don't show anything when I hit OK, and the second page (adjustments) also doesn't move.

ANY suggestions appreciated!

Developer (2 edits)

It's strange that it stopped working all of a sudden. Nothing has changed in Freerider itself for sure. I suspect there must be something in your operating system/drivers that has changed. If you're using Windows 10 - there was an automatic Windows 10 update a few weeks ago that broke the USB joystick input. The way to get that fixed was to roll back to the old windows libusb drivers. Here are a few links:

Windows 10 USB driver fix

www.youtube.com/watch?v=rk6bjS4PEWI

www.youtube.com/watch?time_continue=4&v=SDnRSL3rDwM

(Also make sure that your Taranis is connecting as a joystick an not as a mass storage device. I'm sure that's an obvious thing, and since you have been using it for so long without problem I don't think that's the issue but I thought I'd mention it anyway...)

Thank you - it was the driver problem. I found that none of the suggested fixes worked exactly for me. So, just keep trying - I found this one the most helpful: http://liftoff-game.com/tutorials/Liftoff-Windows-10-Reinstall-Remote-USB-Driver.pdf

Developer

Great, glad you got it solved! Thank you for the link and thanks for reporting back!

same here just out of the blue no longer seeing mine either. im lost. i redid the model and uninstalled and reinstalled the game but with no luck...... and i did every time i plug in it asks if joystick or mass storage.... i cant get it to read the qx7 either

Developer (1 edit)

Did you try the solution in the post above?

Are you seeing your Frsky Taranis as a joystick in Control Panel>Devices?