Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Homegirl Pro

A fantasy console inspired by the Commodore Amiga · By poeticandroid

Windows versión fails to start [solved]

A topic by SiroVai created 32 days ago Views: 61 Replies: 10
Viewing posts 1 to 11
(1 edit)

Im using latest version in a windows 10 machine but when I try to start it a windows is opened and suddendly it is closed and nothing happends.

The same occours with previos version.

Developer

Hey.. sorry to hear about that..

are you running it from the itch.io app or straight from download? if you're using the itch.io app, try reinstalling Homegirl from it.. I had the same issue with the latest update, but reinstalling seemed to fix it..

if that doesn't work, maybe your config.json file is invalid.. open %APPDATA%\Homegirl\ in explorer and delete/rename config.json and try again..

I have reinstalled from the itch.io app with the same result. Have erased config.json with no result.

Will try modifing the config but without seeing any error is difficult to know what to do.

Developer

I just pushed out a minor update to Homegirl Pro.. I don't suppose that solves your issue..?

If not, maybe try running the debug version.. you can get it from github..

Well. Now that I can use the debug version I see the problem but dont know how to solve.

Perhaps is a problem cos I have ñ and spaces in my path?

I paste here the log.


C:\Users\Johan R. Muñoz\AppData\Roaming\itch\apps\homegirl>homegirl_debug.exe
Powering on...
Config file: C:\Users\Johan R. Mu├▒oz\AppData\Roaming\Homegirl\config.json
no config! creating default.
Lua err: [string "sys:libs/screen.lua"]:50: Invalid font!
Powered off.

Developer

ah.. perhaps that could be it.. I'll look into it..

Developer

as a workaround, you could try and create config file in the same folder as the binaries and name it `homegirl.json`, then put the following in it

{
    "drives": {
        "sys": "./system_drive/",
        "user": "../../../Homegirl/user_drive/"
    },
    "network": {
        "cache": "../../../Homegirl/network_cache/"
    },
    "permissions": {
        "sys": 4294967295,
        "user": 65280
    }
}

Thanks. Will try tomorrow.

What I have done is copy the "sys:" drawer to C: and change the path only to verify if is a path problem and yes! It works!

Obviously it not an elegant solution.

Developer

Okay! I've fixed the bug!

turns out the problem was with the FreeImage library, which couldn't seem to load unicode filenames on Windows.. anywhere else in the code it works fine.. so now the gif files get loaded into memory before they get decoded by FreeImage.. problem solved :)

Yes! Now It works! Thank you and Amiga Rules!!

Developer

🙂