Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Luna Engine MV

A script that modifies RPG Maker MV UI easily · By Archeia

Disappearing Hud

A topic by ZeroBeat032 created Oct 15, 2019 Views: 183 Replies: 6
Viewing posts 1 to 2
(2 edits)

I've been messing around with this mostly in battle so far and noticed something odd. It seems to be in tandem with YEP_X_SelectionControl. If you use an item or any action on yourself, your hud  with faces/hp/whatnot will disappear. I tried it in the sample project too just to be sure it wasn't something I was messing up. I'm honestly not sure where to report this kind of thing and I know how busy everyone is, so I'm not really expecting anything. just wanted it to be known that this even happens I suppose. 

Developer

It's a setting in yanfly's battle engine.

Oh wow it is? I've only noticed it though when the SelectionControl is turned on... when it's off everything works fine and the hud stays where it should during any action that selects a party member.  I'll keep looking though since I need the Selection plugin for something specfic. I find it odd anyway it's only when the plugin is on and even more so it only does it when you select party members. Thanks for answering, I'll look through the associated plugins again to see if I missed something.

Developer

Just in case, can you provide a video?

(1 edit)

sure, I can do that. So when I use State Explosion, aka something that works on you and/or a party member (same result with items), the hud disappears. BUT, this only happens when the YEP_SelectionControl plugin is turned on. I scoured that, the Battle Engine, and the Target Core and I'm unsure of what is causing this. Oh and I noticed with certain animations... the actor/enemy with stay in the hue of whatever that animation is unless or until another animation is casts on them. but I'm not too worried about that at the moment. I'm mainly curious why the hud disappears and why only when you use things on yourself. Other than these tho, I'm not having any other issues with this during battle.

Developer

Hey there, the video is private.

oops sorry about that... I switched it to public.