Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Framerate is always limited by screen refresh rate in fullscreen mode

A topic by shmerl created Jul 16, 2019 Views: 54 Replies: 3
Viewing posts 1 to 2
(1 edit)

I tried to run some benchmarks using new Mesa-aco compiler vs regular llvm compiler with radv (on Linux) and Helium Rain. I use Mesa Vulkan overlay to measure framerate. Unfortunately, no matter whether vsync is on or off in the settings, the game caps framerate at monitor refresh rate for me, so I always get 60 fps. Is there some way to uncap it?

Developer

Hi shmerl! 

Try adding this in ~/.config/Epic/HeliumRain/Saved/Config/LinuxNoEditor/Engine.ini.

[/Script/Engine.Engine]
SmoothedFrameRateRange=(LowerBound=(Type=Inclusive,Value=40.000000),UpperBound=(Type=Exclusive,Value=999.000000))

This should effectively disable framerate smoothing, and ensure you can get higher framerate. 

(1 edit)

That didn't work. I also noticed, that in windowed mode, it's not capped, it's only capped in fullscreen. Could it be something similar to this?

https://gitlab.freedesktop.org/xorg/xserver/issues/20

Though that issue linked above happened to me only in Wayland session with XWayland with other game, and now I'm running Helium Rain in regular X session.

Developer

Well that's weird, but then it also looks like a Xorg or Wayland issue - or a desktop environment issue. I believe we found out at some point that under Gnome Shell, vertical synchronization was basically forced by the desktop environment because it would take our raw frames and push them at vsync - regardless of whether we wanted that.