Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Strive for Power

Fantasy Slave Management/RPG Erotic Game · By Strive4Power

Can't use several mods at the same time

A topic by perseus525 created Jun 21, 2019 Views: 440 Replies: 4
Viewing posts 1 to 4
(2 edits)
  1. Game version: ver.0.5.24c
  2. OS: windows 10
  3. Description: As the title says, it is not possible for me to have multiple mods working at the same time, at least, not ones that affect the same file.
  4. Replicate: Quite simple, just download the mod "Play as Any Race mod" that is currently at the top of the mod section and activate it along with the "Constants" mod,  neither should work.
  5. Savefile: I have none since the aforementioned mod combination let's you see if they are working from the main menu  and story mode character creator. 
  6. Workaround: I found a workaround at least for now. Since the problem seemed to be from 2 mods modifying the same file I tried taking the code from the "Any race mod" and pasting in the "Constants" mod file. It worked and the mods are now playing nice (though I only have "Constants" active since it's mainmenu.gd holds the code for both mods)

Unless the creator of a mod has told you it can run with another mod, there's no reason why it would work. If they both use different files then it'll probably be ok though.

(4 edits)

Thing is that the modding guide actually warns you about the possibility of several mods modifying the same file and gives a workaround so that said mods can play nice with each other. However said workaround is not working. That's why I consider it a bug, if I hadn't read the modding guide, I wouldn't have given it a second thought.

There is also the fact that both me and the author of "any race mod" can't use certain mods in conjunction on a windows 10, but he claims that he CAN on a windows 7.

I just did a bit of testing at my main Windows 7 computer, it seems the entire mod menu can break if there's more than one mod active at a time. (Windows 7 or 10.) This doesn't seem like a mod issue, but a version issue. (0.0.24c) My mod, in particular, shouldn't be incompatible with any other mod at all. (Except another sort of "play as any race" type of mod.)

(4 edits)

@perseus525 @nujuju299

Edit 26/5/19 - not sure if just something i done with enable/disable so many times while deving, but if i include same file at all it doesnt load random_portaits version (higher in load order). So maybe not just <AddTo X>, since i removed that line in version 0.2

Thats likely a limitation with using <AddTo X> on same target from 2 or more mods (with seemingly any X, though exact behaiviour varies depending on the X). Without knowing the other mods @perseus525 was trying to use, i couldnt say for sure.

Theres also obvious cases where not using <AddTo X> would still end up with disabled mod code, such as the AricsExpansion + Mirror mod, which both implement large rewrites, effectively hiding eachother it appears (only lightly tested)

Ive noted the <AddTo X> bug in my v0.1 of my mod, Minor Tweaks https://itch.io/t/492874/minor-tweaks-mod-v03

I couldnt figure out a fix by myself, like i said the behaiviour varied, but even using -1 on both mods wouldnt merge both, best you could get is one or the other, often times neither would actually merge.

As a side note, Im unsure if this flashed up as a message in the console window, after hitting 'apply' then 'close'. 

If you know whether the console window output is saved somewhere, please say, might help speed this up.