Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

[solved] Two STM 1.8.16 issues

A topic by mrtenda created May 16, 2019 Views: 136 Replies: 2
Viewing posts 1 to 3
(3 edits)

Hey! I'm having a couple of strange issues ith the latest STM on Unity 2019.1.2f1. The second issue seems to only happen for me after I upgraded to 1.8.16, while the first one actually still happens after I reverted back to STM 1.8.15. I tried reproducing these behaviors in a separate sample project but couldn't manage to do so, so I'm hoping that the information below is enough to go on... Do you have any ideas about why these two issues would be happening? (This is all with the non-UI STM, btw)

  1. When STM is <paused> in a string, if I move focus to another window besides the Unity editor, then come back to the Unity editor, SuperTextMesh.reading returns true, when it would have returned false if I hadn't taken focus away from the Unity editor. This happens for every line of dialogue in my game (which are usually in the style of "<e=voiceon>Text goes here<e=voiceoff><pause> <e=end>").
  2. For some lines in my game, the text now strangely displays all spaced out like this:

  3. If I click the text or anything, it suddenly jumps back to how it's supposed to be:


1. In Unity's preferences, what is "Auto Refresh" set to? Does this behavior change when you change this value? What about toggling "remember read position" in STM's inspector?

2. I've been hit with so much work over the past few days and I *know* this bug looks familiar, but I just can't place it. All I changed in 1.8.16 was adding the <y=> tag and superscript/subscript so... if you change line 2580 from "info[i].pos += pos;" to "info[i].pos = pos;", does it make a difference? This will effectively stop superscript text from working, and is the only part of 1.8.16's updates that touch the main text rendering cycle.


We solved this outside of the forums, but here's the solution:

1. This is something already in the "notes" section of the docs! "Tabbing out of the Unity editor and back in might cause a text mesh to redraw. This does not happen in builds. To disable this in the editor, go into Preferences, and turn "Auto Refresh" off!" So... that's the solution! It doesn't effect builds.

2. I submitted an update that hopefully fixes this. Fingers crossed!! 🤞