🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Aven Colony

Aven Colony is a sci-fi colony-building sim - create humanity's first settlement on an extrasolar world! · By mothership, Mothership Entertainment, ellie_team17


A topic by dorukasama created Nov 04, 2016 Views: 444 Replies: 5
Viewing posts 1 to 4
(Edited 1 time)

Well hello there.

Since in struggling with the instalation trough the .exe zipper and is not working... I wonder how can I add the game that I already purchased from the website so I can try a new download and an instaltion via the app.


Did you create a login when you bought the game on the website? If so, it should be in your account when you use the app. If you didn't, then I think you need to email support@itch.io because we have no control over that. We'd help you if we could!

No I havent created an account. Ill contact them.


By they way...you guys could add some kind of support for the installing problem trough the .exe since there are alot pple having teh same issue.

Im running W7 home premium x64

(Edited 2 times)

@dorukasma, I had trouble running the game after reinstalling Win7. I also had downloaded and run the zip file and did the roaming file thing. Trying to run the game with the itch front end didn't work for me, still doesn't, just generates an error message and wants me to sign up to get another web site. My advice is find some other way. I got my game working buy updating Windows, (there 96 updates one of them was the one Aven needed). To this day the itch is worthless, all it does is crash and want you to sign up to different web sites. It's more adware than anything else. Try running Windows update and see if that works. I would avoid the so called "launcher."

(Edited 1 time)

Thanks for your advice. I have updated the W7 like 2 times today. In total over 230 updates. And still the same problem with the same error.

Dunno what else to do.

This is the error I get when I launch the game


Try running the game without the launcher. When I try to start the game with the itch launcher I get the same thing, it's a different number but the same basic error. Try running the game from the AvenColony.exe file. For me it's located at C:\Aven Colony\aven-colony-windows-beta. Then look for the file, I am not sure if Windows hides exe files by default or not you might have to change that setting if you can't see it. It should be the first file after 2 folders. Double click it and see if the game starts. That's the way mine runs, i just made a shortcut to it on my desktop.