Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Far Blade

Far Blade 3d Pixelart Boss Rush Adventure · By bcubedlabs

Official Bug/Issue Thread Sticky

A topic by bcubedlabs created Apr 02, 2019 Views: 553 Replies: 21
Viewing posts 1 to 11
Developer

Provide any bugs or issues you ran into in this thread

(+1)

There is a visual bug when the squid attacks that kind of displaces the whole image on screen. I also can't seem to dodge sometimes, like if i never pressed the A button. Seems really interesting and i will come back again soon to check any changes :D Go for it folks, if i can look up or test anything for you, write me anytime

Developer

Does the visual bug happen every time or was it random? Thanks for the feedback on the dodge as well.

Tried again today and it seems to happen every time, not random

(1 edit)

The same bug happens to me. I think it may have to do with the camera or something

Deleted post
Developer

Hi,

I'm not very well versed in LINUX but this person appear to have the same error and more when googling it.

There were no errors when the build was made so I think one of these should help!

https://answers.unity.com/questions/404131/how-to-run-the-exported-game-on-ubuntu.html

https://askubuntu.com/questions/254220/there-is-no-application-installed-for-executable-files

Deleted post

Dodging doesn't seem to work (maybe 1/10) while I'm locked-on.  Instead of doing the side-hop he sort of freezes for a split second.  When I'm not locked-on dodging works fine.  I'm on the windows build.

Hi there,

There seems to be an issue with the mouse when playing on a computer that has 2 screen.

While I know you don't need to move the mouse, I still do it without thinking about it and found out that if I go out of the screen bound my mouse is on the desktop so when I click the game lose focus. 

Windows build

I can second this, probably just need to set 'Cursor.lockState = CursorLockMode.Confined' in a start function somewhere, then set 'Cursor.lockState = CursorLockMode.None' when the menu is opened, then reset to Confined when the menu is closed. (Confined only works on linux and windows)

When cutting the tree trunks in the opening area of the game, there is a slight hitch before it cuts in half and falls down. Having worked in Unity myself I thought maybe it would be because you are instantiating the two new halves of the tree or something from prefabs. If it is an intended delay then nevermind, but if not, you might look into memory pooling to avoid stuff like this (Unity isn't great about instantiating things)

I could be way off base on this and sorry if it sounds like I'm "telling you want to do", but *shrug* I like talking "shop" with people who use Unity.

Developer

No worries. Appreciate the input. I am not instantiating, I have a delay when ever something reaches zero health in the game for impact.

I was wondering if it was intentional. Sorry for mistaking a design choice as a bug. Have you considered tweaking it at all? I wonder if a slowdown then speedup would look cool. DOTween does wonders with stuff like that. Anyway, cool game and thanks for taking my light criticism.

(1 edit)

Hi. I know this is a silly problem to have but I am playing this game with a resolution of 3440×1440 and sometimes the immersion breaks due to "cracks" in the outer edges of the game:


Otherwise I really enjoy the style of the game. Well done :)

This is something I'm genuinely curious about. Do these ultra-wide monitors have the option to let you show a normal 16:9 resolution but have it just center it and then crop out the sides? I'm working on a 2d game right now (I know this isn't technically 2d but it plays as one) and I can tell you that the thought of having to accommodate these types of resolutions is kind of disheartening. 

As far as I am aware, yes. If the content aspect ratio is 16:9 it is displayed in the center of the screen with black bars to the left and right. So nothing to worry about unless your game selects the native screen resolution by default.

Developer

Wow thanks for pointing this out! Never would of thought of this happening. BTW nice monitor :)

i'm getting kinda frequent crashes on the second screen (i think) where it tells you that you can use "A" to roll and "B" to sheath your sword or whatever

When using a controller (xbox one controller specifically) I've found that the dodge button works at best sporadically while locked on with Y, and perhaps more problematic the trigger just....isn't blocking

Hi. My character dropped off the map at while they were taking stairs after the first left path ("choose a path"). They were  stuck running underneath the map from that point on. I haven't been able to reproduce it yet though.

(+1)

When playing on OS X the X-Box controller (USB) mapping seems to be wrong. The stick for movement works but none of the buttons. Is there anything I can do to help debugging that?

yep same here!

I have the exact same problem with the wireless controller