🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

FPV Freerider, useless, annoying "calibration"

A topic by andk created 325 days ago Views: 1,044 Replies: 14
Viewing posts 1 to 10

I've posted about this before, trying again - maybe I once can actually fly this thing. (video's based on current released version, a day old or so.)

It's on Ubuntu, everything else works fine with the interlink "radio"

FPV Freerider, behaves randomly at calibration, messes up inverting, range, gives asymmetric range (cursor goes much more one way than the other) - and - maybe sometime gets it right. - but still impossible to achieve perfect symmetry.

Then - it does no good, because when the app is restarted, the shitstorm starts again, it even looks like where the throttle is when starting the application, influences how badly, it will be off, requiring the awful calibration again.

Please ! - make a normal, decent calibration like any other application, I've never seen a complex mess like this, with lots of sliders, - and still are unable to get good calibration every time.



I don't know if this could apply to your case but that is the way I calibrate my radio in ubuntu:

  • Install (if you haven't already) the jstest-gtk package
  • Plug your radio in the PC and launch jstest-gtk program
  • Center all sticks then do the calibration within the program
  • Now, exit from jstest-gtk without moving the sticks and launch FPV Freerider
  • Go to the controller calibration, keep the sticks centered until requested to move them
  • Do the calibration stuff...
Now the radio should be correctly calibrated... try and let us know.
(Edited 1 time)

whatever you do in jstest-gtk has no actual influence.

Centering sticks there, and starting with centered stick does help, but only because the FPV freerider has a defective calibration method. - there is normally no need for another application, or considering stick positions when starting an app.

The asymmetric range is not correctable anyway - due to broken calibration.

*no* other application I ever tried, behaves this bad - for example, I can just use, after one calibration, the interlink with X'plane - or use yoke and throttle quadrant for FPV Freerider with same pile of problems - that no other simulator or application shows.

I am not asking to hop thru loops to make it work, just hoping that the author cares to add an actual calibration routine that just works.

Developer (Edited 1 time)

I'm sure it can be fixed if you keep calm and hold a positive attitude.

There are plenty of people using Freerider successfully on Linux. I'm not a Linux user myself but there are often some very helpful people over at the official RC Groups thread: http://www.rcgroups.com/forums/showthread.php?t=23...

(I'm pointing you over there since you were unable to solve it using MiSKLaCH suggestion and I'm not sure how many other Linux users are actively reading here.)

(Perfect symmetry is not needed by the way, the important thing is the centering).

.Yes, but how can it even be affected by where throttle stick is at startup ? - that defies the whole point of storing calibration.

Messing up axis invertion should not be possible as well. It's the only application that behaves that way, would you please just make it like "any" other joystick calibration ?


The link you sent to a discussion thread , - when searched for work "calibration" (only that) - returns 17 pages of results !

I am frustrated because I bought it long time ago, mentioned the problem (apparently as many others) - and see that it's still ignored.

"Perfect symmetry is not needed by the way" - so, hitting full pitch forward can give a given pitch rate , but full back, something different, - also.. when roll left hits 100% , roll right may be restricted to 90% . in a any 3D flight , that would be a awfully poorly tuned vehicle.


Please observe that no other application has this amount of sliders and gadgets for joystick calibration.

Normally, you assign axis, manually or automatically, then ask user to center, and do maximum and minimum input. - and there you have it, values that can be scaled to internal attitude demand numbers, no need for manual sliders to move things up and down.

Finally - where a stick is during application start, is not supposed to have any influence. Just imagine if you had to restart Xplane every time pedals, throttle quadrant , trims, or the yoke were in anything that perfect center.

it would be nice to have the problems fixed, not tell people how to try to workaroud them (and still have imprecise controls.)

Developer (Edited 2 times)

My guess is that it's something with the joystick drivers on your particular setup that is doing something unusual. You should only have to calibrate once, and once that works, the simulator remembers the settings and they will be exactly the same the next time you start up the sim. If the behavior is different at different start-ups it must mean that the output (from your radio via the operating system) changes somehow. (Either that, or that your operating system somehow keeps Freerider from actually saving the settings. On Linux, they can be found in ~/.config/unity3d/[CompanyName]/[ProductName] I believe, so you can check if they are kept correctly).

You should know that I have spent a lot of time working with the calibration to enable it to work with most operating systems and USB controllers/dongles/radios. There are so many different variables, and some devices that give very strange values. I am developing in Unity and am using Unity's input manager the best way I can.

This is happening to me too. After many hours with no issues, the program will now register yaw or aileron with no input from the transmitter. The fix is that every time I have to re- calibrate the tx. I also notice it is running slow now, less frames... weird behavior, been great for a couple weeks. Uninstalled, reinstalled, using itch, win 10 64 bit. gaming rig.

Developer

Seems like something must have changed on your system. Perhaps some drivers auto-updated.

Yeah, I think I got it fixed. Great program btw, thanks.

Deleted post

why always the system and never the software ? mine is doing this now after I just bought recharged :(

and i paid extra to support the devs :'(

(+1)

Interesting to hear how it's supposed to be and how it actually works for people.

Thanks MiSKLaCH for sharing your experience!

I'm doing my calibration slightly different on my standard Ubuntu 16.04. That's what I did:
  • Install (if not present yet) the "joystick" package. It provides commands like "jscal", "jstest", etc.
  • Connect radio (in my case: start Taranis and then connect the USB port on the back to you computer)
  • Calibrate radio within Ubuntu by running "jscal -c /path/to/joystick" (in my case the Taranis was mounted as /dev/input/js0 device, so I used: "jscal -c /dev/input/js0")
    Follow the instructions on the screen. After a precision test, you will need to move all your analog joysticks to the min/center/max positions accordingly one after the other.
  • Once the calibration is done, you can check it using "jstest /path/to/joystick". This will output all actual joystick values that are transmitted to the operating system. For my Taranis I have 8 analog axis and 24 buttons. 4 of the analog axis correspond to my joysticks (channels 1 to 4) and I can verify that all analog values range from roughly -32000 to +32000 (the range of a signed short value) when I move my sticks. Furthermore I can verify that there is no dead zone around the center of my joysticks.
    In my case running "jscal -c /dev/input/js0" resulted in the calibration I was looking for.
  • If you are fine with the calibration in your operating system, get the joystick calibration via "jscal -p /path/to/joystick". You should get a line similar to:
    "jscal -s 8,1,0,0,0,4227201,4227201,1,0,0,0,4227201,4227201,1,0,0,0,4227201,4227201,1,0,0,0,4227201,4227201,1,0,0,0,-2147483648,-2147483648,1,0,0,0,-2147483648,-2147483648,1,0,0,0,-2147483648,-2147483648,1,0,0,0,-2147483648,-2147483648 /dev/input/js0"
    This line is used to restore your specific joystick calibration after you disconnected and connected it again.
  • Create a script which restores your joystick-calibration and afterwards runs FPVFreerider
  • If you centered all your joysticks before and during startup of FPVFreerider everything should be fine. However, my throttle stick is usually not centered during startup and thus I need to run the calibration in FPVFreerider every time. I can not confirm that it reuses the settings of the previous run, since I get different results when starting with different initial stick positions, while jstest returns always the same value range regardless of my initial stick positions.


Some helping references I used:

At my current point of view, I would simply like to turn off the internal calibration in FPVFreerider and see how it works. However, this is probably not the best solution for most other people, resprectively needs some further testing and evaluation before releasing. I'm currently discussing with the author on how to evaluate this option. Furthermore, I'll take a closer look at the configuration file stored by FPVFreerider and see if I can figure out something. Maybe I'll find some time over the weekend for further analysis.

Until then, all the best,
Stefan

this is soooooo annoying !!

I haven't tried in an Ubuntu machine but in a Kali Linux distro from a usb stick and I never had any calibration issues, neither with my Taranis nor with the Turnigy Evolution.

Freerider calibration's settings seem perfect to me, and saves the settings without any issues.

ffs it worked on the demo then i buy the game and pay etra fr dev support and now it wont calibrate the same xbox controller.

Developer (Edited 1 time)

Thanks for your support. The demo and full version uses the exact same input method. Check if you can think of something that has changed on your setup.

If more than one controller/input device is connected at the same time that might cause a conflict.

If connecting via USB, make sure you uninstall vJoy and Smartpropoplus if you have them. Their driver messes with things when connecting via USB.

If you provide more info on what operating system/controller you are using someone might be able to help.