Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

The good old classic spinning camera problem!

A topic by Traggey created Mar 10, 2019 Views: 3,230 Replies: 5
Viewing posts 1 to 4

Hey-o, just picked the game up, can't play! Camera keeps spinning, using a  DS4 controller hooked up via DS4 windows, however even with the gamepad unplugged and DS4 windows turned off, the camera keeps spinning as if a secondary controller was plugged in and is snatching inputs, only problem is that there is no such controller plugged in! Any idea what's up?

Update, plugging my PS4 controller straight in seems to be running even without DS4 windows, neat!
However, plugging the PS4 controller in makes the camera spin endlessly.
Also why on earth is Square the confirm button? What kind of spray paint have you been sniffing! <3

(2 edits)

The game was designed for xbox 360/xb one controllers, 'cause they're actually a totally official controllers for all modern pc games. Sometimes game developers adds DS4 controller support too, but not so offently.
It seems like the game won't support Dual Shock 4 so good as x360/xbone controller. That's so much for most pc games. In the game's launcher there's manual controls mapping. Have you tried to remap properly?
About camera spinning. I guess, one of the axis for camera movement is mapped like (AXIS Z- "left analog  stick - left") and the ps4 left trigger is (axiz z- = trigger at default possition, axiz z+ =trigger pressing). That's why the game thinks you pressing analog, when you actually didn't do anything.

P.S. Butterflies' confirm button is 'A' on Xbox controller by default. 

Oh wow that's super odd, DS4windows just emulates the PS4 controller to be an Xbox controller, this is how I play all my games (Inluding JSR and JSRF) with no issues, the odd part was the fact that the controller worked without running DS4windows, meaning the game somehow reads my PS4 controller by default, I believe this is cause of the faulty input mappings.

Fiddled around some more, tried with an Xbox360 and Xbox one controller and the same problem, so it's not the PS4 controller!

Looked into the default input mappings and they're completely bonkers, had to manually change it all and now it sort of works, however as I've not been able to play the game properly I've no idea what inputs to bind to which buttons so it's taking a lot of trial and error to get this right.

Developer

That's strange. I remember someone else getting weird default bindings with a DualShock, but nothing about spinning. It does remind me of a bug I had years ago on another game with a cheap old controller, but it feels like a long shot from there. Go figure. I didn't do an in-game rebind menu because Unity infamously doesn't support rebinding at runtime with the default input manager, which my input relies on (namely the nametags). What I could do is make it possible to switch those nametags around.

Sorry I'm so late to the punch.