🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

LaserDock

A topic by giantmecha created Sep 22, 2016 Views: 1,114 Replies: 29
Viewing posts 1 to 15

Hello! Is the current version of Maxwell compatible with LaserDock?

Developer

The current version is not, but there will be an update coming out (soon) to coincide with the release of LaserDock that will be compatible with LaserDock.

Thanks!

Another question: is it possible to get audio out of Maxwell? I hear it ever so faintly from the laser projector. :)

Developer

At the moment Maxwell is purely an abstract generator - there is no audio coming out of Maxwell. What you may be hearing are resonant frequencies of your galvos.

Gotcha, thanks. Wondering if there's a way to somehow reflect Maxwell's abstract output as audio (from another application)...

Hi there, is it possible with your software to display text with Laserdock? thanks

Developer

No, not at this time. Maxwell is mainly for creating swirly / geometric style images.

thanks for the answer!

Well, the LaserDock is out. Just waiting for the Maxwell update.

Thanks

Developer (Edited 1 time)

The Windows x64 version has been released. Make sure to install all files & drivers included with LaserDock first.

Is the Mac version now compatible with LaserDock?

Thanks ;-)

Developer

All versions are now compatible with the LaserDock

Will Maxwell work with the APC Mini controller?

http://www.akaipro.com/product/apc-mini

Developer

Yes. Maxwell can be controlled by any MIDI controller.

Once purchased, how many instances of Maxwell can I run

Developer

Are you asking about "simultaneous" instances or total installed instances?

Maxwell currently can only run a single instance per computer - however, you can install on multiple computers. You can also install Mac & PC versions once purchased.

Hi, just purchased Maxwell for my LaserDock. Using Win10 x64 Redstone 1 on an HP Elite X2 1012 G1. I notice the Gui interface cuts out about 3 CM of the right side of screen running in fullscreen. Changed resolution but makes no difference. If the brown background frame was removed(gui control interface cropped) then I think it would solve the issue.. haven't tested on other devices yet.

thanks

Developer

Ok - thanks for the report... Do you know what resolution your screen is at fullscreen?

hi, 1920 x 1280 (WUXGA+) 192ppi. happy to test to help fix. Cheers

I am having a problem, I just got this application and have a LaserDock that's working with it's application but I get nothing from Maxwell, I brought up Max Console and have the following,

Error 126 Loading external jit.maxwell,

Gen working in runtime mode

getattr num_dacs is not valid attribute for jbogus

getattr dac_id is not a valid attribute for jbogus

the color of the text is yellow and the final is just a path for saved content.

I am at a loss but for my boss this works fine but he is using a mac I am on win 10 64bit

Developer

That's certainly a strange error - have not had this reported previously. I need to do some digging around.

Can you send me an email to johnny.lightspeed at gmail.com and we can work through the issue there?

Hello, I just downloaded the latest version on Windows 10 64-bit. I have a LaserDock and it works with their software. Whenever I try to turn on the laser, nothing happens. No matter what I do, it always shows a DAC ID of 0x00dbcb1b, with the light off next to it. Even if I disconnect the LaserDock and launch the app, it still always says this. If I select LaserDock in the drop down, or try changing the DAC index, nothing happens, still showing the same DAC ID with the light off.

Any help appreciated!

Developer

This is the behavior you would get if Maxwell is unable to connect to the LaserDock. Most likely this is a driver install issue.

Wickedlasers has posted some driver install/fix instructions here:

https://www.reddit.com/r/LaserDock/comments/57djk9...

Pasted here :

Download this http://zadig.akeo.ie/

  1. Connect laserdock
  2. Open zadig
  3. Choose Laserdock Interface 0
  4. Choose libusbK as driver
  5. Click install.
  6. Repeat 3-5 for interface 1 and 2
Let me know if this works for you!

Thanks for the quick response. When I ran zadig, all 3 were already listed and set to libusbK. I re-installed them all, but everything is acting exactly the same.

Developer

Dang... This is weird for sure. Lets move to email - send me a note : johnny.lightspeed at gmail.com. If you could take a screen shot of what the Laser section looks like when you choose LaserDock that might be helpful.

Developer

I think I may have misstyped the email address:


Can you try lightspeedjohnny at gmail.com


Also, Wicked Lasers has released a new Windows driver with the latest build of their app. Can you try that as well:


https://www.reddit.com/r/LaserDock/comments/5gelkb...

(Edited 1 time)

Kind of a late reply as I had to send my laserdoc back for service and the new one came in today, with the new version of Maxwell the old problem I had is resolved and now I get to play with it! Thanks

Hi, I got the most recent version of Maxwell (1.4.1 for OSx) a few days ago, and am unable to get it to connect to my LaserDock. I have a Mac. Are there any instructions on how to help Maxwell find my Laserdock? I downloaded the two JSON files (the Getting Started Presets) but don't understand what I am supposed to do with these files. Wondering if that is the issue.


THANKS

Developer

On the Mac, everything is simply just plug-n-play. There is no additional software you have to install other than Maxwell.

But just to be clear, here are the steps:

  1. Connect LaserDock to a USB port on your Mac
  2. Start Maxwell
  3. Choose "LaserDock" from the DAC TYPE dropdown in the Laser section of Maxwell (lower right corner).
The DAC ID should report a non-zero number, and the LED to the right of DAC ID label should light up. If this doesn't happen, follow the steps above and post the results from the "Max Console" : Menu->Window->Max Console

Here is a screenshot of what the Laser section should look like:

http://imgur.com/txlSsAz

Thank you! I have no idea what I was doing differently previously, BUT it works!!! Thanks!