Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Spinnortality

Spinnortality is a cyberpunk management game where you run a megacorporation. · By James Patton

v07.02 & v18.02 don't work on Mac

A topic by TomViolence88 created Feb 23, 2019 Views: 93 Replies: 9
Viewing posts 1 to 9

Having the same issue as this guy: https://itch.io/t/367976/601-will-not-start-on-mac - just with the 2 most recent versions.

Can I please get a refund?

I just replied on that thread:

This issue has been fixed, BUT it relies on the game being placed in a folder where the game has read privileges. For one user, this just meant taking the game out of the Downloads folder - try moving it somewhere else and trying again?

If that still doesn't fix it then of course you can have a refund, let me know :)

Hi, James. Thanks for the reply. I never opened the game in the Downloads folder. Tried moving it around (even into the Downloads folder) without any luck. Any other ideas?

Hi James. I'm also on a Mac, and it's also not working for me. It lets me get as far as choosing difficulty settings, but the "play" button does nothing.

I moved it into my games folder and made sure it had all the necessary permissions.

That is so frustrating, I'm so sorry! Could you guys send me your log files? They should be in "~/Library/Logs/Unity/Player.log".

You can send me an email with the log at jamesdavidpatton [at] gmail [dot] com.

Sorry, James, but there's no directory with that name on the Mac or in the Spinnornality folder.

Also tried the new version, but same issue.

Can you access the ~Library folder at all? (Be aware: ~Library is a hidden folder, and there is apparently a duplicate Library folder that is not hidden by default.)

This post does a pretty good job explaining it: https://www.macworld.co.uk/how-to/mac-software/show-hidden-files-mac-3520878/

Hi, James! I brought my Mac to work the other day to ask one of my IT colleagues to look at the issue. And guess what? He fixed it.
It was something with the read privileges as you said, but other than that I don't it. Thanks for a lot for your support, though. :) Looking forward to getting started playing.

NO WAY! I'm so glad you got it fixed! Thanks for following up here, by the way: it's good to know what caused this so that if it happens again I can tell that person "um hey look it's almost definitely the read privileges".

Hope you like the game now you've finally got it working! :)