🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

3dn file rejected

A topic by Duke Serkol created 359 days ago Views: 382 Replies: 17
Viewing posts 1 to 13

Greetings everyone,

I'd like to first say this emulator is absolutely incredible, thanks to all who made this possible!

Now on to my problem: I decided to make my own 3dn file for Akumajo Dracula (the cart version, the one with the difficulty selection). I don't know if the Castlevania one publicly available would have worked or not, I was doing it for fun really (I'm that kid that would spend hours messing with the colors while playing with the Super GameBoy).

Today I had a friend come over and wanted to show him the difference when playing the game with no customized 3dn, so I took the 3dn file out of its directory and showed him the game without it (I made no modifications nor did I save a new 3dn).

I then shut down the emulator and put the 3dn file back in the proper directory, booted the game up... and it still was like there was no 3dn file at all.

I immediately shut it down again, made a copy and tried several things, such as editing a couple things and saving (overwriting) the 3dn file (making it go from 8mb to 400kb) to then copy and paste the back up to overwrite the changed file. I tried creating an all new 3dn file and replace that with the back up.

No luck, my old 3dn that I put so much effort into (played through the whole game twice to make sure there were no unresolved issues) simply will not be loaded/recognized.

Can anyone help me out? Or should I just accept that, somehow, I unwittingly flushed hours of work down the drain?

I know it sounds like a dumb question, but did you try rebooting the PC?

I was getting a different error after I uploaded my 3DN files to google drive and tried to re-open them again. It would say that there was a sharing violation on the file. Shutting down 3DNes and exiting Google Drive didn't work. The only way I was able to get it to work again was to reboot my laptop.

I would really have a hard time believing that you wasted hours of work as long as your backup 3DN remains unchanged. If rebooting doesn't work, I would uninstall and re-install the emulator and see if that worked.

Good luck.

Tried rebooting, nothing. By uninstall and re-install, you mean delete the directory and files and then extract them again from the zip file? If so, then just tried that (also gave the new directory a different name just in case). Unfortunately it didn't help.

Thankfully though, the other games I made 3dns for are still okay, I was afraid moving the games directory might mess them up too. I'm guessing what caused the problem was starting up the game while the 3dn was gone (strange as that may sound).

Guess I have to start over with that game :\

Right.... there is no install for 3DNes.... nevermind about that. I really don't know why this is happening. You didn't delete the backup 3DN file yet, did you?

I know this is a stupid question too, but you're sure the backup file is renamed to the exact name of the rom and the extension was changed from .bak to .3dn, right?

Starting up the game while the 3DN was gone wouldn't have caused it. I've recovered bad 3DN files with the backup this way before. If you saved the 3DN while there was no 3DN file and your only .BAK file was there though, it may have saved a new 3DN file and saved over the good .BAK file. In that case you're out of luck.

(Edited 1 time)

Hold on... .BAK?

I'm not familiar with this extension. Is that just how you rename files to keep them as backups? (Me, I just copy them indifferent folders) Or did I completely miss a file type the emulator uses?

Anyway, I do still have the back up and I'm certain it has the same name as the game since I didn't change the name at all and when I tried copying it back into the games' folder and booting it up to then save some changes from the otherwise default appearence of the game, the copied file went from being 8mb to 400kb... so yeah, it definitely was overwritten.

Really weird, isn't it?

Whatever folder you open the rom from, there will be a .3DN file and a .BAK file. (Well, there will be assuming you've saved the 3DN twice)

The first time you save a 3DN file, it creates a ".3DN" file. The second time you send a 3DN, it creates a new ".3DN" file and the old ".3DN" is saved as ".BAK". This is a nice backup feature, but it only serves as a safety feature for one save. I don't believe this was covered at all in the manual yet, so don't feel dumb that you didn't know about it. I wrote a whole suggestion post to create a more complex backup system than this, not even realizing that the emu's creator already had this basic version already in it.

If you weren't aware of the .BAK file, I'm wiling to bet that at one point it was about 8MB itself, but if you've saved the 3DN twice with no work done on it since then, it's probably only around 400kb again.


if you still have your own saved backup file, try uploading it and posting a link here and I'll try using it myself. I'm not familiar with the game. Is this the Famicom version of Castlevania?

It is yes. Castlevania was originally released on Famicom Disk, but like Legend of Zelda it was later given a cartridge release too. This is what I've been playing. It's almost the same as the western release of Castlevania except for the title screen and the addition of an easy mode.


(Note the copyright dates)

Here's the 3dn

https://www.dropbox.com/s/ps6rqdiw3mic9wf/AkumajoD...

I wish I had some better news for you, but that's an 8MB file I can't figure out. I ran this game both with your 3DN first and then once again with no 3DN file and both times it was exactly the same as if nothing had been saved to it.

Now that it's up, geod might have an idea about what's happening here. I've worked quite a bit on about 10 games so far and nothing like this has ever happened to me yet. I'd really love to know how this happened and work under a reasonable assumption that it won't happen again.

(Edited 2 times)

what 3dnes version are you using? I will investigate and try to fix the 3dn file and return it back to you

I used 1.1b3 to test out Duke Serkol's 3DN.

(Edited 1 time)

and i ask the version he used to create it. the bug was already fixed in 1.1b3

Ah, so it's a known bug. That certainly explains it as I was using v1.0

It would be great if you could fix the file... but only if it doesn't take too long. I wouldn't want to rob you of precious time that could be used to improve the emulator further. I'm sure the community would have you work on that rather than fixing some dude's 3dn file for an obscure version of a popular game.

That said, if you can fix the file and it meets the required quality standards, I would be happy to submit it to the repository :)

You might want to try the newest Castlevania 3DN file in the repository. Assuming that it's the exact same game except for the title screen I'd be willing to bet that most of the work would show up on Akumajo Dracula as well. Obviously it would be different than your file was, but you could run through and tweak things and re-release it if you wanted to. Obviously you'd have to re-do the title screen and any levels that weren't completed too, but you wouldn't have to start from scratch if it works.

I might do that... but first let's see if Geod can work his magic.

Sorry for the late response. Too busy for the 1.1 release.

Here is the fixed 3dn file:

AkumajoDracula.3dn

Awesome, thank you!!

And don't worry about the wait, I definitely don't mind if it means the release of the next version approaches faster :)

Mh... some things aren't working the way they did before. I wonder if it's because the 3DN broke or because it was made with an older version of the emulator. Either way, it's no big deal, I should be able to fix it all up with another playthrough.

I had to remove the incorrect part of your 3dn so of course a small amount of work would be lost :)

(Edited 1 time)

Ah, I see, that makes sense.

I couldn't be sure if it was something like that which got corrupted or some kind of header part, but yeah, I suppose I should have figured ;)

Anyway, I'm still very grateful for the fix, thank you!