Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Autonauts

Make and teach robots to automate the world! · By Denki

Game not Booting

A topic by Mr_Zig created Dec 28, 2018 Views: 160 Replies: 5
Viewing posts 1 to 6

Hello everybody...

I am working on linux Xubuntu 18.

The Autonauts.x86_64 does not work, I do have an "non valid encoding" file witten on the Autonauts directory.

So, I start the game with the Autonauts.x86.

When I start the game, I have the "screen resolution and graphics quality" comming, but as soon as I click on "validate" nothing happend...

What should I do?

Thanks for your help...

Developer

Can you send me this file please? Hopefully there will be something useful in it :)

~/.config/unity3d/Denki/Autonauts/Player.log

Hello Denki


Here the data:

Preloaded type GtkListStore
Preloaded type GtkWindow
Preloaded type GtkVBox
Preloaded type GtkImage
Preloaded type GtkNotebook
Preloaded type GtkHBox
Preloaded type GtkFrame
Preloaded type GtkAlignment
Preloaded type GtkTreeView
Preloaded type GtkLabel
Preloaded type GtkCheckButton
Preloaded type GtkScrolledWindow
Preloaded type GtkComboBox
ensions: name=VK_EXT_debug_utils, enabled=0
Vulkan error VK_ERROR_INCOMPATIBLE_DRIVER (-9) file: /home/builduser/buildslave/unity/build/Runtime/GfxDevice/vulkan/VKContext.cpp, line: 279
Vulkan detection: 0
No supported renderers found, exiting
 
(Filename:  Line: 525)


best Regards...

Developer

OK so the error seems clear "No supported renderers found". Looks like it's a video driver problem, presumably because of your hardware combination. I don't really know anything about Linux but searching for VK_ERROR_INCOMPATIBLE_DRIVER yields many links. You can maybe find one for your particular hardware. Sorry I don't have a specific solution.

Denki

In fact I have Autonauts working fine on 2 other computer working fine under Xubuntu.

So I tryed on a other one as at the begining of this post.

I had the same mistake, so I install the vulkan driver on my linux "Xubuntu".

and here the player.log data:

Preloaded type GtkListStore
Preloaded type GtkWindow
Preloaded type GtkVBox
Preloaded type GtkImage
Preloaded type GtkNotebook
Preloaded type GtkHBox
Preloaded type GtkFrame
Preloaded type GtkAlignment
Preloaded type GtkTreeView
Preloaded type GtkLabel
Preloaded type GtkCheckButton
Preloaded type GtkScrolledWindow
Preloaded type GtkComboBox
ulkan init] extensions: name=VK_KHR_external_memory_capabilities, enabled=0
[Vulkan init] extensions: name=VK_KHR_external_semaphore_capabilities, enabled=0
[Vulkan init] extensions: name=VK_KHR_get_physical_device_properties2, enabled=0
[Vulkan init] extensions: name=VK_KHR_get_surface_capabilities2, enabled=0
[Vulkan init] extensions: name=VK_KHR_surface, enabled=1
[Vulkan init] extensions: name=VK_KHR_wayland_surface, enabled=0
[Vulkan init] extensions: name=VK_KHR_xcb_surface, enabled=0
[Vulkan init] extensions: name=VK_KHR_xlib_surface, enabled=1
[Vulkan init] extensions: name=VK_EXT_debug_report, enabled=0
[Vulkan init] extensions: name=VK_EXT_debug_utils, enabled=0
Vulkan detection: 0
No supported renderers found, exiting
 
(Filename:  Line: 525)


Could you help me please?

Thanks for your help and support.

Best Regards

Developer

Can you try forcing the game to run in with OpenGL please? Add "-force-glcore" to the command line