Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Evolution

Create creatures and let them evolve to see how they master various tasks. · By Keiwan

Neuron network size

A topic by SVKAker created Dec 26, 2018 Views: 999 Replies: 2
Viewing posts 1 to 2
(2 edits)

Hello, i have really problem with getting some normal behavior from creature, after a long time it never do any easy walking, even when i use pre-builded spider creature.
Is there problem in size of neuron network? Or if i wait long enough it will get always best possible?
Normally when i have creature with 10 bones ane 9 muscles then i can spawn 50 creatrues at once. I always get at least 2 batches per generation, that take 100 creatures per generation. And even though i wait 300 generations it dont even learn to jump.
I even tried more complex neuron network like, INPUT = 36 + 27 + 18 + 9 = OUTPUT... not better.

Now i trying to jump with with this creature:

I spawn 80creatures per 2 batches, with 50% mutation rate... after 445generations it dont do even just one normal jump. Here is short video:


Can somebody help what can be wrong? or any advice what to do to get normal behavior?? thx

The first major thing it could be is too many neurons / too many layers. The more neurons you add, and especially the more layers you add, the more generations you need for it to train. Once it does (eventually) get trained, it will perform better than one with less neurons, but the significantly longer training time might not be worth it. I just recreated your guy with the default 10 neurons in 1 hidden layer and am on 22% fitness by generation 100. 

The other thing it could be that the creature is physically not adept at being able to jump or run due to its structure. I modified it as shown below and at generation 60 it's at 28% fitness 


I know this is an older thread, but I thought it was interesting. Shirtandtieler clearly put a bit of time/energy into working with this design & I thought I might mess around with it a bit myself. Unfortunately, I can't seem to replicate the reported results for the life of me, tried more than a dozen different runs and this is pretty representative of what I get:


a floppy monstrosity that inevitably capsizes or pitches forward onto its side. Perhaps I've missed something with the layout?