🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Intel GPU (HD5500) not compatible with LWJGL2.0

A topic by chris_camacho created 1 year ago Views: 266 Replies: 4
Viewing posts 1 to 5

2.0 is quite out of date, and 3.0 is awesome, look at upgrading (will make your life easier in the long run!)

Exception in thread "LWJGL Application" java.lang.ExceptionInInitializerError

at com.badlogic.gdx.backends.lwjgl.LwjglGraphics.setVSync(LwjglGraphics.java:555)

at com.badlogic.gdx.backends.lwjgl.LwjglApplication$1.run(LwjglApplication.java:122)

Caused by: java.lang.ArrayIndexOutOfBoundsException: 0

at org.lwjgl.opengl.LinuxDisplay.getAvailableDisplayModes(LinuxDisplay.java:954)

at org.lwjgl.opengl.LinuxDisplay.init(LinuxDisplay.java:738)

at org.lwjgl.opengl.Display.<clinit>(Display.java:138)

... 2 more


This is the usual output I get from LWJGL 2.0....

Developer

Looks like according to the github issue that libGDX is still in the process of upgrading to LWJGL3. But I gave it a quick test and didn't run into any immediate issues. So I'll post that and invite you to the MoonBase Testing version later this evening if you wanna give it a try.

oh sure use it! I've been using the LWJGL3 "driver" in libGDX for a while now, it just works as far as I can tell...

Developer

Check your email :)

Works well, thanks!