Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Juice Galaxy (formerly Juice World)

Floppy ragdoll rpg sandbox with physics-based combat · By fishlicka

The mac version menu will not appear.

A topic by coco9905 created Apr 04, 2023 Views: 415 Replies: 11
Viewing posts 1 to 2
(1 edit)

I've played the mac version before, it worked pretty well, now it has ceased functioning. When I boot up the game, it does get past the loading screen, but I can't do anything past that except watch my little colorful dude walk forward for all eternity. I would also like to mention that before the latest update, similar things happened when entering the Toilet Realm.

Developer(+1)

Hey there, thank you for your report!

So, if I understand correctly, the buttons show up but cannot be clicked on?
I cannot get the issue to occur on my own Mac computers-- but one thing you can try is simply reinstalling.

If that doesn't work, can you answer a couple questions for me?
1. What version of Mac OS do you have?
2. Do you usually install using the itch.io app, or simply download from the JG web page?

I look forward to fixing this for you,  sorry for the trouble.

(1 edit)

I clicked around a lot to see if anything would happen, the exit button worked but is invisible, I assume the entire menu is invisible but can still be clicked on.

Unfortunately uninstalling and reinstalling did not work.

The OS I have is Ventura 13.0.1

I installed via the itch.io app.

Happy to let you know and thank you for your time.

Developer (1 edit) (+1)

Thanks for getting back to me!

I'm actually at a loss for what could be causing this. Would you mind sending me the error log?

You can find it at:
~/Library/Logs/Fishlicka/Juice Galaxy/Player.log
and send it to:
JuiceGalaxyBugs@gmail.com

to access the Library folder, you may have to hold the Option key while using the Go menu in Finder.

Email sent. Let me know if you need anything else.

Developer(+1)

I've uploaded a test build that may fix this issue--

If you wouldn't mind running it and letting me know if it works, I'd appreciate it!

https://fishlicka.itch.io/juice-galaxy-test   /   password: plswork

(3 edits) (+1)

When I clicked on the link, I couldn't download the test build and there is an error.

Error.JSON:RPC error 12000: itch.io API error (400):/games/623823: invalid game

Edit: figured I should try online instead of app, I could download it and opened it.

The menu is still invisible, I will send you the errorlog.

Let me know if you need anything else, also I am wondering if something is wrong with my mac.

Edit-2: Having trouble finding error log.

Developer(+1)

It's alright, I don't need the error log anymore.

Darn, I was really confident I'd fixed it. I changed a lot with the main menu last update, so I was kind of expecting there to be new issues. There have been other reports of issues with the GUI, so hopefully I can figure it out soon.

I will give this another shot within the next couple days, thank you for getting back to me so quickly!

Developer(+1)

All right, one more try if you don't mind!

I've upgraded from Unity 2019 to Unity 2021, and fiddled with the menu system a bit more. If this doesn't fix it, idk what will.

The link to the test build is the same as before:
https://fishlicka.itch.io/juice-galaxy-test   /   password: plswork

Sorry. It appears to be having the same problems. Hopefully there's some minor flaw with my mac or something, the thing's pretty old.

Developer

Wow, that's so unfortunate... it's just weird that it worked up until now.

I'm going to get back to work on the next update and keep thinking on this. I'll let you know here if I come up with any new leads.

Thanks again for your reports and all your testing! Sorry I haven't found a fix yet.

(+1)

Thanks, I'll let you know if it magically decides to work in a future update or something. Good luck with development.