Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

PixelCNC: Fast/Easy CAM for Signs, Art, Engravings and More!

CAM software developed by artists for artists to create unique and original works on a 3-axis CNC router or mill. · By Deftware

Not quite sure

A topic by Donnie created Feb 03, 2018 Views: 348 Replies: 11
Viewing posts 1 to 8
(+1)

I've been watching your product page since your announcement.  I was waiting for you to release a version other than 1.0a before I pulled the trigger.  I noticed that you have released 1.1a but removed the special price.

Well, I downloaded the new version and tried to load a 170x170 image.  It has been stuck in "generating parallel milling operation" for over 15 minutes.  Stuff like this is why I was waiting for another release to purchase and am leary to purchase at $100.  This was nothing special.  60 ipm, .125 endmill, .05 step, .06 doc.

I had to kill the product in task manager.  It tried another image and same thing.  I cannot get it to work if I change any of the default settings.  I also noticed that any naming that I do for the cutting and milling operations I create do not stick.

If I can get 1.1a to work properly and you re-instated the special price, I would be in for purchasing.

I like the product, a lot, but just waiting for a release beyond the first to join in.

Thanks,

Donnie

(1 edit) (+1)

I'm also having a similar problem with the app hanging after loading an image and trying to generate a mesh. The program becomes unresponsive after a minute or two and I have to kill it in task manager. I initially thought it was due to complex images but it also happens with some pretty simple images.

Developer

Hi Bill, thanks for using PixelCNC. Can you give me some more details on what exactly you're trying to do so I can try to re-create the problem myself? I haven't been able to re-create Donnie's problem with his parameters:


Hi,

Can you let me know which parameters you need? Basically, the majority of the images that I try to load aren't able to generate a mesh. After loading the image, the generating mesh status displays and after a short while the program hangs with a "not responding" message. Since loading the image is the first step, I can't change the other parameters.  Attaching 1 of the images that causes the hanging.

Thanks,

Bill



Developer

Alright Bill, I figured out the issue: there's too much image noise - with all the white spots everywhere, like what you'd see on a Xerox.  I get the same problem with the image you posted so you were right about it being the images, or at least this one (I'm assuming you have more that are also scanned Xeroxes?) PixelCNC is designed to handle both black/white binary images as well as depthmap/heightmap images, and the noise is being interpreted as details in the image, which in combination with the actual details is proving too much for default triangle/vertex buffers PixelCNC allocates at startup. As long as the noise is there you'll end up with a mesh that's riddled with little islands/bumps.

I'm going to tweak some internal settings to reduce the triangle-count a bit, which sacrifices some detail, but the mesh that generates at startup is just used for a preview of the form the image would produce if interpreted as a depthmap. I'm also considering adding some code to just re-allocate the triangle buffer if it reaches its extent - the end result here will be that a computer that doesn't have enough memory will resort to using the harddrive as a backup, but once the triangles are uploaded to the GPU for rendering it shouldn't matter anyway. At the very least it should give the user some kind of error message instead of hanging!



Here's your same image, after being cleaned up a bit. I could do a cleanup function in PixelCNC that does this automatically, but it would require the user to fiddle around with some parameters as each image is different, and some images are not black/white binary images (i.e. relief depthmaps). The user would have to fine-tune some parameters and use their best judgement. This would be the beginning of PixelCNC having a fully functional imaging component as well, the goal of which being that users can quickly design up basic images right in PixelCNC, plotting shapes and lines, gradients, text, etc..

But v1.10a simply is unable to handle the image as-is. After increasing buffer sizes this is what your original image yields:


This can still be used to do some outlining, and some V-carving:


I increased the triangle and render geometry vertex count allowed while also reducing the complexity threshold of the mesh to better accommodate larger and more complex images. I also added code to create a messagebox for end-users to see in the event of a problem, so that it's not tucked away in the log file. This way they can quickly report what happened in their initial report for a quicker turnaround.

I'll have v1.11a up ASAP.

Developer

(I replied but accidentally deleted the message trying to repost it, doh!)

I can't recreate the problem on my end with a .05 step and a .06 depth of cut, I'm going to need some exact details in order to recreate the problem. What dimensions does the project have that you're working with? In case there is any confusion the 'Cut Depth' parameter specifies the depth each individual cut pass will be while the project's actual Z depth (or Max Depth, whichever is smaller) will be the total depth all of the cut passes will result in. If you have a very deep project I can imagine a computer running out of memory while trying to generate a toolpath with many cut passes, potentially hanging the program. I'll write a note to add some code for detecting if this is what is happening and pop up a notice for the user, but my instincts tell me you may be having a different problem.

I replied to Bill above with an image showing that a 50 thou step over and 60 thou depth of cut are perfectly fine for PixelCNC, at least on my end. If you could give me exact details and perhaps your system specs (CPU make/model/speed, system RAM, GPU) we should be able to figure it out and get things working for you. Thanks for trying PixelCNC!

Developer

Also: when you set the name of an operation it will only stick when you hit 'Apply'. I just added a todo list item to fix it so that it doesn't show the name changing just from editing on the left-side where it lists the operations until the Apply button is actually pressed (which may make it appear that the name has changed). Alternatively, I could just set it up so that editing the name always sticks without hitting apply - and do the same for the tool editing mode.

Developer

..and one last thing: could you guys both also post your log.txt files? It should be under c:\Users\[user]\AppData\Local\PixelCNC that should prove useful as well. Thanks again :)

My log file was 240mb when I checked so I deleted it and ran pixelcnc again to generate another. The new log is over 11mb and I'm not sure how to upload it here. Please advise.


Thanks

Developer

It's okay, the logfile I'm 99.999% sure is full of messages about mesh triangle overflows, I'll have the v1.11a up soon, I just have to finish adding some code for showing an error messagebox to make it simpler for users to report errors they encounter so that the logfile can serve as more of a backup in the event that more complex problems arise. Thanks!

Thanks a bunch and looking forward to giving the new version a try :)

Hi, I purchased pixelcnc and want to download the new version. Where do I download the paid version?