🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Itch app gives a Certificate error on startup, can only close the app

A topic by Huitzilopochtli created Dec 25, 2017 Views: 208 Replies: 11
Viewing posts 1 to 12

I just updated the itch app on windows 7 after not updating for like two years, and as soon as it starts it shows the following error:

"

Certificate Error: net::ERR_CERT_DATE_INVALID

There was an error with the certificate for img.itch.zone issued by Let's Encrypt Authority X3.

Please check your proxy configuration and try again.

If you ignore this error, the rest of the app might not work correctly.

"

It gives the options of ignoring and continuing, and quitting, but the ignore and continue button does nothing, I can only quit, and can't access the app at all.  I tried uninstalling and reinstalling, which itself was sort of confusing because the itch app doesn't add an uninstall option to the all programs folder, nor does it have an uninstall program in the installation folder, so I just deleted the folder from where it was in AppData\Local, then reinstalled, but it didn't do anything to fix the problem.

Same for me... Win 7 too

I have this exact same problem with Windows 10.

(+1)

Same error here. Also, images aren't loading properly in the website. It seems to me that some SSL certificate expired for Itch and things are breaking because of that.

App gives the same error, also no images on the website for me.

Having the same issue here. Reinstalled the game, ran the .exe as Admin, ran the "update" file as Admin, nothing seems to fix it as of yet.

(Edited 1 time)

Temp fix: Change your time and date on your computer back. I just set mine back to the 18th to test it. App works, not sure about the website yet.


Edit: Website images load, too.

Same as well.

(+1)

You can still use the app if you continue clicking 'Ignore and continue' for every game in your library/collection.

The game generates an individual error window for every single image it tries to fetch, including thumbnails.

Good catch, @Arithyce!

(+1)

Fixed.

yeah, it's fixed now.