Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Mon-cuties for All

Starting a new chapter in your life, you move to a farm and enter the world of monster farming! · By Reine Works

Game Won't Start

A topic by Metaparadox created Dec 16, 2017 Views: 537 Replies: 4
Viewing posts 1 to 4

I tried running the game and got the following:

I'm sorry, but an uncaught exception occurred.
Before loading the script.
Exception: Couldn't find file '._archive.rpi'.
-- Full Traceback ------------------------------------------------------------
Full traceback:
  File "/Volumes/STORE N GO/Mon-cuties-0.5-mac/Mon-cuties.app/Contents/Resources/autorun/renpy/bootstrap.py", line 295, in bootstrap
    renpy.main.main()
  File "/Volumes/STORE N GO/Mon-cuties-0.5-mac/Mon-cuties.app/Contents/Resources/autorun/renpy/main.py", line 300, in main
    renpy.loader.index_archives()
  File "/Volumes/STORE N GO/Mon-cuties-0.5-mac/Mon-cuties.app/Contents/Resources/autorun/renpy/loader.py", line 163, in index_archives
    fn = transfn(prefix + ".rpi")
  File "/Volumes/STORE N GO/Mon-cuties-0.5-mac/Mon-cuties.app/Contents/Resources/autorun/renpy/loader.py", line 615, in transfn
    raise Exception("Couldn't find file '%s'." % name)
Exception: Couldn't find file '._archive.rpi'.
Darwin-14.5.0-x86_64-i386-64bit
Ren'Py 6.99.12.4.2187

I'm using a Mac, trying to run the game from a flash drive.

Developer

Hi!

Based on what you pasted from the message and some research we did, the error seems very rare (we were only able to find one other case of it) and is most likely exclusive to Mac OSes. We recommend trying the following:

1. running the game off your hard drive directly

2. re-downloading the game files (we've uploaded a new Mac version that uses the latest version of the game's engine)

3. running the .exe through Wine (this was the other case we found's solution)

Unfortunately, there's not much else we can do without more information. Do other Ren'Py Mac games give this error on your system? What version is your OS? Etc.

I've been able to play other Ren'Py games with no problem. I have OS X 10.10.5. I'll try re-downloading the files.

It worked!

Developer

Glad to hear it!