🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Noob here: How do I export this to Unity with textures attached?

A topic by TTerebesi created Dec 02, 2017 Views: 439 Replies: 1
Viewing posts 1 to 2

Hello,

I'm new to Blender and already learned a lot about the program by using Sprytile. Now I may not see the obvious solution here, but everytime I export my model (that has the textures from the spritesheet already applied to it) and import it into Unity I get the model without any textures. I know that the process of UV unwrapping exists, but I don't understand what exactly I have to do in order to see the same result in Unity as I see in Blender, how to create a UV map or how to create a material in Blender that I can apply in Unity. So if anyone could point me in the right direction for Sprytile specifically, that would be a great help!

Thanks in advance.

Developer(+2)

Hi TTerebesi, happy to hear that Sprytile helped get you into Blender! When you import your .blend file into Unity you get a folder called Materials beside your blend file. The materials in this folder is where you would set the texture/tileset.

First thing to do is import your texture into your Unity project and adjust the texture import settings.  Select the texture and in the inspector, set it to the following settings.


Next, you'll have to adjust your materials. Go to the materials subfolder and edit each material in there, change the shader to Unlit/Transparent Cutout and set your texture/tileset into the material.


These are basic settings for materials, feel free to play around as you get more familiar with Unity. This material also doesn't do double sided rendering, that's a bit more complex to setup in Unity.

You may see seams inside Unity. The easiest way to fix this is to select the camera and change the Rendering Path setting to Deferred.

Technically, the best way to fix this is to set auto pad offset to 0.20 in Sprytile but unfortunately the defaults aren't set to that.