🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Videos don't play in game

A topic by RickyMarchant created 7 days ago Views: 33 Replies: 3
Viewing posts 1 to 4
(Edited 1 time)

So I recently updated my game, Mastermind. Everything works except the videos don't play after the last submission by the user. There is just a 5 second pause. It's weird cause when I just made it an executable file to play/open on my desktop the videos worked  fine. However, on itch.io the video doesn't play. Any thoughts?


I guess I should mention the source is a video clip ( and not through a URL) with Unity and I've tried game on my mac and PC and both had same issue.

Admin

Have you tried running the game with your browser's console open to see if unity reports any errors? We don't manipulate the game files in any way when you upload them. We display exactly what you sent us in an iframe.

Thanks, leafo.   I'm seeing this error:    Cannot play media. No decoders for requested formats: video/x-ms-wmv

Ok, seems some other people have had this issue (with a quick google search). I'll dig a bit and see if I can find anything.

Might be a Unity issue as my professor for my class posted the same error on a different website. I'll try to come up with a fix but if anyone was able to resolve this please let me know!

https://forum.unity.com/threads/unity-webgl-videoplayer-not-working-no-decoders-...