Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Not Downloading?

A topic by randompeepur created Feb 13, 2016 Views: 10,895 Replies: 15
Viewing posts 1 to 14

Hey, I'm pretty new here so I'm not really sure how to exactly fix stuff around here. The thing is, I tried downloading a game from this site to my mac and it worked the first time. But, I just tried downloading a game right now and it's not downloading at all (I even switched my browsers). I noticed that on the bottom of the page (I'm using google chrome) for where the URL would be displayed would always read javascript:void(0) for every single game and I don't know if this is normal.

Can anyone help me?


Is this related to the app? Or downloading games on in general?

I think it's for the in general. Sometimes it downloads sometimes it doesn't and it's weird.

me too this happens for me too


Are you downloading from the website our our app? Could you tell us what happens?

Make sure you aren't using any download managers, since they aren't compatible with downloads from our website. If you want resumable downloads then I recommend you install the app.

I am having the same issue on both the website and the app, I click the download button and nothing happens on the website, and on the app the game will stay at 'Starting download'

Same here

I find the download won't work if the game has been set to "disable all payments". Turning payments on (even if the default is $0.00) means the download works. Not sure if there's anything you can do as a user, however.


I tried downloading it from the website and then it says Network Error and when I press resume it says Failed - Forbidden 


I just tried downloading some games and I'm having issues with Chrome only. Works with Edge/IExplorer...


Same here on the app

I am seeking new game, where to download game here?



I cant download anything on the app it just says no compatible uploads were found for this title


not downloading the app, help?

I have been using the app and two games HotPot and GalaxyRushroom are not working for me. I am not able to download them and add them to my library. I see a similarity between them though - they both are contained in zip files. A lot of games are I think but every game I downloaded so far are just in folders - nothing like a zip file. Other than that I'm not sure how or why I'm not able to download them.


This topic has been auto-archived and can no longer be posted in because there haven't been any posts in a while.