🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Not a regular file, can only WalkSingle regular files

A topic by quantumduck created 20 days ago Views: 45 Replies: 2
Viewing posts 1 to 3
(Edited 1 time)

Hello everyone,

Butler had been working fine, have uploaded at least a dozen or more builds, but suddenly I'm getting an error message.


 not a regular file, can only WalkSingle regular files

*errors.errorString 0.3.9.34: not a regular file, can only WalkSingle regular files
C:/Multi-Runner/builds/58469115/0/itchio/butler/src/github.com/itchio/butler/vendor/github.com/itchio/wharf/tlc/walk.go:89 (0x7460f6)
C:/Multi-Runner/builds/58469115/0/itchio/butler/src/github.com/itchio/butler/vendor/github.com/itchio/wharf/tlc/walk.go:78 (0x745c75)
C:/Multi-Runner/builds/58469115/0/itchio/butler/src/github.com/itchio/butler/push.go:385 (0x8c8200)
C:/Go/src/runtime/asm_amd64.s:2337 (0x45e8c1)

tried Butler login to make sure my credentials are good, looks to be.

status gives me no channel found which is to be expected, I tried erasing the copy I had already uploaded.


Any help is greatly appreciated.


M.

I seem to have fixed the problem. 


It looks like it was related to having the files in a OneDrive folder, something probably related to the recent Windows 10 OneDrive files on demand update. I made a build in another folder and that one is uploading just fine.

M.

Admin

Thanks for the update!

OneDrive seems to be causing a bunch of problems, both with butler & with the app. If we get more reports I'll definitely take a look  at it.