🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Game does not work after (re-)upload

A topic by Zorg created 32 days ago Views: 115 Replies: 10
Viewing posts 1 to 8
(Edited 3 times)

Hey,

i corrected a small error in my prototype https://chriszorg.itch.io/normal-prototype  in Unity, compiled it (WebGL), created the zip, deleted the old zip file on itch.io and uploaded the new zip file (via Firefox). But the game does not start. I am getting a JavaScript error: SyntaxError: expected expression, got end of script (UnityLoader.js). And: 

Invoking error handler due to TypeError: UnityLoader[r] is not a function.

The game works perfectly when i'm using the index.html in the offline folder.

I tried re-uploading the old zip file which was working before, with the
same error as a result. I have no idea what's going on or if i'm doing something wrong. :/

Getting the same things, I can view past projects that have been uploaded previously just fine, but uploading the same builds that are being displayed already on one webpage is now giving me errors on another after re-upload. I think the webserver might be improperly configured since I can run it off localhost but cannot host anything onto itch without this error.

(Edited 1 time)

Thanks for replying. Good to know i'm not the only one. :)

You may be right with your webserver configuration assumption.
Somebody gave me ahint that it could be a MIME type thing.
See: https://forum.unity.com/threads/webgl-netcoreapp-1-1-unityloader-js-syntaxerror-...

But if that's the case there is nothing we can do about it on our end, right?

I've been getting the same error... stills with no solution.

(Edited 1 time)

Yeah, i am seeing the same thing - uploaded a build just fine on friday. For me the issue started yesterday and not with a re-upload but with the first upload.

(Edited 2 times)

I did not change anything but it works now.

andreasboye i like your ZENGRAMS game, btw. :)

Thank you! It means a lot :-)

I played it yesterday to level 38, today i advanced to level 62 before i took a break.

Good job! Almost done then, it's fairly short.

Admin(+1)

Hey, sorry for the trouble. We deployed an update to our html5 extractor but it didn't play nice with our CDN. We rolled back the changes until we get it stabilized. If you're still having issues with an upload I recommend trying to re-upload it.

(Edited 2 times)

Thank you for the fast bug-fix! :D