Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Mutiny Island

Mutiny Island is an open-world style pirate game. Reclaim your ship, The Red Dawn, by any means! · By Elushis

Game Keeps Dropping to 0 FPS, Sound Still Works

A topic by GCTuba created Apr 11, 2021 Views: 72 Replies: 2
Viewing posts 1 to 3

Hey, I would love to try this game out but the video keeps freezing. I can still hear sounds and my character walking around and stuff so input still works but I get 0 FPS. This happens every couple minutes which makes playing impossible since I have to keep restarting. I have an i7-6700K, RTX 3080, and 16GB of RAM. I've tried running as administrator and disabling antivirus to no avail. Is there anything else I can do?

Developer

Hey! Sorry to hear but thank you for posting. Based on what you described I'm not sure but I'll try my best to help. Is the game launching in full-screen for you? Does this happen on the title screen or only once you've started a file? When is the exact moment? 

Try pressing F4 to take the game out of full-screen, Maybe you could try changing the resolution in the game options menu, if the title screen is available/working for you. I'm not expecting this to work but you never know with these kinds of things.

I haven't tested the game on the RTX 3000 series but I'm currently using a RTX 2070 with no issues when trying to play the game. Hopefully we can figure out what's going on! Is there some sort of setting on the Nvidia panel you may have toggled that could be conflicting or something along those lines?

Developer (1 edit)

Hi again! Just wanted to share a small update on this particular issue. I tested the game on a GTX 1650 this week and had something similar occur.

The game would work but then occasionally seem like it would drop to 0 FPS, but you could still clearly hear the character moving/game environment if you continued to press buttons. Changing the resolution to 1920X1080 within the games option menu on the title screen fixed it up.  Just posting in-case this works for someone else as well.

Edit: Adjusting the settings in the Nvidia GFX Panel also helped.