Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Gearend

Explore an abandoned robotics facility as a customizable robot. · By SolarLune

[SOLVED] Crepescular Ray corrupts some areas

A topic by Metroidvanias.com created Aug 04, 2017 Views: 369 Replies: 10
Viewing posts 1 to 11
(1 edit)

While Crepescular Ray is enabled, outdoor scenes look like this:

Intel 2600k, 16 gigs RAM,, Nvidia 980ti

FIXED: I went into the Nvidia Control panel and reset my global settings back to default.


Great! Glad to hear - I was wondering what the issue was, haha. I thought it couldn't be something with the shader, since we have the same graphics card manufacturer and it looks like the shader was working correctly, and just wasn't being added on top correctly.

I'm really sorry, but I have to retract my SOLVED. I had disabled rays in that screenshot. When testing the new builds, I noticed rays were off, turned them back on, and got this (first few seconds are black screen because my screen recording hadn't kicked in yet):

I'm experiencing this issue as well. I'm running on a AMD FX 6300 with a GTX 750.

I'm also experiencing this, haha. I don't think I did anything that changes how shaders are composited, so I'm thinking that it might be related to the nvidia driver version we all have installed. What version does everyone have?

I have 384.94. I was planning on updating soon, so if you want I can test it out with the latest.

(+1)

Ah, don't worry about it - I just figured out what it was. NVIDIA must have updated their graphics drivers slightly to eliminate undefined behavior or something - a slight tweak to the crepuscular rays shader fixed the issue. I'll update the game today with the fix.

(+1)

OK, I've updated the game - the fix should be in this last update.

(+1)

Latest version doesn't have the rays problem. Thanks!

No prob!