Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Hypnospace Outlaw

Alternate reality internet simulator set in 1999! · By Jay Tholen, TetroniMike

Hitches every few seconds in Linux (Manjaro 64-bit)

A topic by JP LeBreton created Mar 14, 2021 Views: 310 Replies: 12
Viewing posts 1 to 2
(2 edits)

From the moment I launch the game, the visuals and input (eg mouse cursor) hang for 0.5-1 seconds, every 3-6 seconds. My computer (Intel i7 8700, 32GB RAM, Nvidia GTX 1070) is pretty capable and runs intensive 3D games like No Man's Sky with ease. Stuff I tried while troubleshooting, with no change:

  • launching the game from the itch.io launcher app
  • launching the game executable (HypnOS) from the command line
  • closing down all other applications and GNOME extensions on my system before running the game
  • installing and running from my SSD
  • installing and running the 32-bit version instead of the 64-bit version

Not sure if it's relevant, but I get this in the terminal output right after launching the game:

[2725:2725:0313/195442.651206:ERROR:service_utils.cc(157)] --ignore-gpu-blacklist is deprecated and will be removed in 2020Q4, use --ignore-gpu-blocklist instead.
[2725:2733:0313/195442.652185:ERROR:service_utils.cc(157)] --ignore-gpu-blacklist is deprecated and will be removed in 2020Q4, use --ignore-gpu-blocklist instead.
[2725:2733:0313/195442.665675:ERROR:nacl_browser.cc(290)] Failed to open NaCl IRT file "jpl/game/hypnospace-outlaw/nacl_irt_x86_64.nexe": -4
[2752:2764:0313/195442.760816:ERROR:cert_verify_proc_builtin.cc(559)] No net_fetcher for performing AIA chasing.
[2752:2763:0313/195442.761380:ERROR:cert_verify_proc_builtin.cc(559)] No net_fetcher for performing AIA chasing.

Have any users reported something like this before?

Developer

Okay this appears to be an NWJS issue.  If you are feeling adventurous, could you help me out with trying the following on your computer and see if it fixes the problem.  I was able to reproduce it and fix it by doing the following:

The blacklist/blocklist problem can be solved by doing the following:

  1. Open the Hypnospace Outlaw install folder
  2. Open package.nw (it's a zip file in disguise, you don't have to unzip it)
  3. Edit the package.json file inside - you'll see "--ignore-gpu-blacklist", go ahead and replace it with "--ignore-gpu-blocklist"
  4. Save the .json file, go back to the .nw file and if it asks you to update the file because it has been modified in an external application, go ahead and click "Update" and then close the .nw file

The NWJS-specific issues may be solved like so:

  1. Download a newer version of NWJS (currently Hypnospace uses 0.49.0), I recommend trying 0.52.0 or 0.51.2:
    https://dl.nwjs.io/
    If you're trying 0.52.0, for example, you'd want to download this file "nwjs-v0.52.0-linux-x64.tar.gz"
  2. Open the Hypnospace install folder.  Delete everything EXCEPT FOR"
    1. package.nw
    2. the data folder
  3. Open the NWJS file you downloaded
  4. Copy over the following files/folders:
    1. swiftshader
    2. locales
    3. lib
    4. v8_context_snapshot.bin
    5. resources.pak
    6. nw_200_percent.pak
    7. nw_100_percent.pak
    8. nw
    9. nacl_helper_bootstrap
    10. nacl_helper
    11. icudtl.dat
  5. Rename "nw" to "HypnOS"
  6. In terminal, use the following command:
    chmod a+x HypnOS
  7. Try running ./HypnOS from terminal
(1 edit)

Excellent, thanks so much for the help, I'm happy to do this to help troubleshoot.

Modifying package.json to silence the warning was no problem.

I downloaded nwjs-v0.52.0-linux-x64.tar.gz and extracted the files listed, except the files nacl_helper_bootstrap and nacl_helper which were not present in the archive.

Launching the new HypnOS binary with these files = no more hitches!

However, the game now appears to be running windowed at its native resolution (480x270?), and fullscreening, maximizing, or resizing the window seems to make it render only a ~480x270 section of an upscaled view in the window's top left corner.

I have no real progress in the game to save, so if any further troubleshooting involves clearing my local config, that's no problem.

Developer

Oh poo I didn't think to check resolution changes... there are a couple different ways to achieve that in NWJS, and iirc some have been/are being deprecated.  I'll have to poke around, thank you again for troubleshooting!

Developer

Looks like the resolution issue may be exclusive to Manjaro - I just tested this in Ubuntu and had another person test in Fedora, and no issues there.  Maybe you can try completely clearing it out and starting over, or maybe try NWJS v0.51.2?  You also might try an SDK version (for example: "nwjs-sdk-v0.52.0-linux-x64.tar").

(1 edit)

I tried uninstalling and reinstalling the game from the itch.io app, and redoing the steps above with NWJS 0.51.2 and then with the SDK version of 0.52 - same result unfortunately.

I wonder what's different about our setups besides the base OS? Manjaro is rolling release so I'm running GNOME 3.38.4, Nvidia binary drivers 460.56, kernel 5.11.2.

Developer (1 edit)

The other player who tested in Fedora gave me a hint at what the issue might be - are you using the X or Wayland graphical display server?  I'm going to be honest I barely know what those are, but this person thinks that if you're using X that might be causing the issues with changing window size.

Yes, I am using X. Wayland is the newer, much more modern display server (drawing and managing windows, handling input, etc) that isn't supported by Nvidia yet, I'd be running it if I could. Most Linux distros do not enable it by default because of various compatibility issues (though the hope is that will change in the next couple years). If I had to guess I'd say a majority of people running Linux games they bought on itch or Steam are still using X.

Developer

Ah okay, well if that is the case then I'm not sure how else to help you here and I'm sorry :(

One thing I was able to do is edit package.json to change the starting size of the window to 1920x1080 (my monitor's native res). This gives me a 3x scaled (1440x810), centered view when the window is maximized, which while not ideal is just about good enough to be playable. That result is obviously pretty different from what you'd get setting the resolution from within the game's code, but maybe that's a starting point for troubleshooting if more players report this issue. (and if not, great!)

Thanks so much for the help troubleshooting!

Developer

Hi there! If you're still struggling with resolution and performance issues, please try using NWJS 0.49.1, I have one person confirming it fixes the problem and does not cause additional issues (at least that they have noticed). Thank you for your patience!