🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Feedback form doesn't open on mobile (iOS)

A topic by joeymaru created Jul 07, 2017 Views: 105 Replies: 4
Viewing posts 1 to 4
(Edited 1 time)

Hello! 

Asked in an email if Mobile support could be in the realm of possibility.
I had tried to put it on a mobile device without thinking about it, and realized it won't show the feedback form when I called Show(). 
There weren't any errors though. :)

The reason of course this would be helpful mainly on iOS, is that we have no way to view what is going on inside Unity in a release build. iOS locks down the app, and you can't even attach to it with XCode after deployed. The bug reporter that ships with Unity is pretty general when it catches an exception, instead of a line number, it will just give you a class and function, and sometimes that isn't really enough to find the problem, having the actual device log would go much farther.

I would be happy to help/test with this if needed!

Developer (Edited 1 time)

Sorry for the late reply! As far as I know, mobile should work, but I haven't been able to test it on iOS. 

It's likely that EF is looking for the screenshot in the wrong place, and is getting hung up waiting for it to appear. Could you try unchecking "Include screenshot" on the Feedback Form prefab? (Double check that it's also unchecked in your scene(s))

I've also edited the title of this post for my own reference (:

Noah's proposed solution works, but I was able to get the screenshot functionality to work on iOS as well by modifying the part of FeedbackForm.cs where the screenshot gets captured. It turns out Application.CaptureScreenshot() uses a different path on iOS than on other platforms, as documented here: http://answers.unity3d.com/questions/339335/ios-app-using-applicationcapturescre.... I added a couple of preprocessor directives that modified the path when on iOS, and the form worked as intended.

Hope this is helpful!

Developer

Thanks so much for posting your solution here! I'll be adding a fix for screenshots on iOS with the next update.

Developer

I've added a (hopeful) fix in 1.0.3. Sadly, I can't confirm that it works. 

Please let me know ASAP if you have any issues!