Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

GMLive.gml

Livecoding for GameMaker: Studio / GameMaker Studio 2 · By YellowAfterlife

(SOLVED) Massive list of compiler errors after updating from Studio 2.2.5 to 2.3.1

A topic by smbmaster99 created Dec 07, 2020 Views: 170 Replies: 2
Viewing posts 1 to 3
(4 edits)

EDIT: Solved

The marketplace was providing me with the wrong download; downloading directly from the IDE worked

Hey there, I originally purchased this asset from the Game Maker Marketplace for Studio 2.2 and today upgraded to Studio 2.3.1. Problem is, when I tried to run the game after importing the (I assume) most recent version of GMLive (which I redownloaded off the GM Marketplace about 10 minutes ago), the game threw tons of compile errors, citing things like:

Script: gml_parser_run at line 439 : Assignment operator expected
Script: gml_parser_run at line 441 : got 'switch' expected '}'

Script: gml_std_StringTools_trim at line 8 : Assignment operator expecte

Script: gml_node_is_simple at line 17 : got 'return' expected '}'

Script: gml_node_equals_list at line 7 : Assignment operator expected

etc etc.

I never had this problem when I used the version of GMLive for 2.2.5, and I'm positive I imported the new download of the asset correctly

What could be the cause of this?

(1 edit)

Forgive the double-post + bump but i had an update:

i managed to get rid of the compile errors by going into the GMLive.gml file and, wherever there was something like

if(expression)++val; else break;

i replaced it with
if(expression){
    ++val;
}
else{
    break;
}

and that solved about 99 % of the errors. The other issue was with GMLive_std.gml, where buffer_get_size() and buffer_set_size() were being passed too many arguments (these two functions only take 3 parameters instead of 5 in Studio 2.3.1)
My game compiles and runs now, but for some reason now GMLive thinks that Studio's built-in functions such as round() and show_debug_message() are "invalid scripts"

so basically GMLive 1.0.38 still doesn't work for me on Studio 2.3.1 but at least the game compiles and runs

Developer

As answered on Discord, this means that you are trying to import a GMS2.2 version into GMS2.3. Marketplace is known for giving out a GMS2 version instead of GMS2.3 when accessing it from the web. Downloading the asset via menu:Marketplace➜My Library in the IDE always gives the right version (2.2 when using a 2.2 IDE, 2.3 when using a 2.3 IDE)