Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Fleshcult

Take the role of an incubus or succubus. Seduce mortals into your lair · By Oneirolith

Game freezing on launch

A topic by Burgers&Bees78 created Nov 12, 2020 Views: 214 Replies: 6
Viewing posts 1 to 2

I've tried everything I can think of so far but when I launch the game it opens to a blank screen and I'm forced to terminate it through task manager, which lists it as 'Suspended'.

 I've tried unzipping the game in various ways into various folders, including straight to my desktop. I even downloaded the Itch app but I got  the same error there. I tried allowing it through my firewall to make sure that wasn't causing any trouble and it had no effect, so I'm really at a bit of a loss.

The only cause for this that I can think of is that I'm running a 64 bit system while the game is 32 bit, but that's not exactly a concrete lead and I'm not an expert by any stretch of the word.

These are the only logs I could find, copied from debug.log.

[1112/142753.105:ERROR:browser_gpu_channel_host_factory.cc(119)] Failed to launch GPU process.
[1112/142753.106:ERROR:gpu_process_transport_factory.cc(1017)] Lost UI shared context.

https://i.imgur.com/8gMf2Mr.png


Any help would be greatly appreciated!

Developer

What sort of graphics card or integrated graphics do you have? The 32-bit on 64-bit thing is totally fine, but not being able to start the GPU process is definitely a problem.

Could you check that there's a subprocess.exe in the cef/ folder? You might get that error if it's missing.

(1 edit)

I have an NVIDIA GTX 1060 3GB, and I found subprocess.exe.

https://i.imgur.com/aATlw5S.png


Quick edit: Just to cover all the bases and avoid missing anything important, I tried running subprocess.exe and received this error.

 https://i.imgur.com/FQ5gUIL.png

Developer

I actually have the same graphics card, so we know that works! Subprocess.exe won't be able to run on its own, the error you see when you do that is normal.

I wonder if it's screwing up when it tries to construct the path to subprocess? What's the path to the folder where it's installed? Is there a game.log too?

Oh neat! I haven't met anyone in a while with the same card.

I figured that was what was going on with subprocess.exe but I wanted to make sure I hadn't missed anything important, so I gave it a try anyway.

I did find game.log though, apparently I'm just blind! As you can see I also tried launching it from my desktop to see if that had any effect but I got the same blank white screen and suspended process as usual.

As a side note to avoid confusion I have unzipped the folder, I just kept the same filename.

https://i.imgur.com/WZO2WRy.png

Developer

I've put a new version up and if you've got time, it'd be great if you could take a look. It uses a different method to construct the file path to subprocess.exe and fixes a bug where errors weren't making it into the log.

Well it seems to be working now! When I first unzipped and launched the game it loaded fully to the main menu but when I closed it and launched it again to make sure it wasn't a fluke it froze immediately. After some troubleshooting I deleted the folder it was in and unzipped it into a fresh one it seems to be working for the time being! I've tried closing and relaunching the game to make sure it still works, and it seems stable, thank you so much for all your help!